GM:S 1.4 [SOLVED] Slayers Upgrade Studio extension error

Discussion in 'Legacy GameMaker Community Tech Support' started by zircher, Jun 25, 2019.

  1. zircher

    zircher Member

    Joined:
    Jun 21, 2016
    Posts:
    379
    At the title says, I tried to run a project with this extension and I noticed two thing. The project began with a 'cleaned' dialog box and when I tried to compile it, it threw a lot of messages. I included a few below. Any idea what would trigger this and how I can resolve it?
    --
    TAZ

    Code:
    Compile Extensions...
    Error : gml_Script_fileBinWriteString(11) : Assignment operator expected
    Error : gml_Script_fileBinWriteString(11) : unexpected symbol "<=" in expression
    Error : gml_Script_fileBinWriteString(11) : malformed assignment
    Error : gml_Script_fileBinWriteString(11) : got '<=' expected ';'
    Error : gml_Script_fileBinWriteString(11) : unexpected symbol "<=" in expression
    Error : gml_Script_fileBinWriteString(11) : unexpected symbol "<=" in expression
    Error : gml_Script_fileBinWriteString(11) : malformed assignment
    Error : gml_Script_fileBinWriteString(11) : got '<=' expected ')'
    Error : gml_Script_fileBinWriteString(11) : malformed assignment
    
    Error : gml_Script_grid3dCreate(11) : Assignment operator expected
    Error : gml_Script_grid3dCreate(11) : unexpected symbol "<" in expression
    Error : gml_Script_grid3dCreate(11) : malformed assignment
    Error : gml_Script_grid3dCreate(11) : got '<' expected ';'
    Error : gml_Script_grid3dCreate(11) : unexpected symbol "<" in expression
    Error : gml_Script_grid3dCreate(11) : unexpected symbol "<" in expression
    Error : gml_Script_grid3dCreate(11) : malformed assignment
    Error : gml_Script_grid3dCreate(11) : got '<' expected ')'
    Error : gml_Script_grid3dCreate(11) : malformed assignment
    
    Error : gml_Script_grid3dDestroy(8) : Assignment operator expected
    Error : gml_Script_grid3dDestroy(8) : unexpected symbol "<" in expression
    Error : gml_Script_grid3dDestroy(8) : malformed assignment
    Error : gml_Script_grid3dDestroy(8) : got '<' expected ';'
    Error : gml_Script_grid3dDestroy(8) : unexpected symbol "<" in expression
    Error : gml_Script_grid3dDestroy(8) : unexpected symbol "<" in expression
    Error : gml_Script_grid3dDestroy(8) : malformed assignment
    Error : gml_Script_grid3dDestroy(8) : got '<' expected ')'
    Error : gml_Script_grid3dDestroy(8) : got 'argument0' expected ')'
    Error : gml_Script_grid3dDestroy(8) : wrong number of arguments for function ds_list_size
    
     
  2. Ali Al - Mosawi

    Ali Al - Mosawi Member

    Joined:
    Jun 20, 2016
    Posts:
    50
    You need to import script again in gms 2 i was imported slayer upgrade scripts in gms2 with no issue
     
  3. zircher

    zircher Member

    Joined:
    Jun 21, 2016
    Posts:
    379
    Oh, I'm using GMS 1.4.999. It was working the last time I touched it, but that was a while ago.

    I also found a debug.log with this error repeated a dozen times...
    [0625/002341.710:ERROR:crash_report_database_win.cc(469)] failed to stat report
     
  4. zircher

    zircher Member

    Joined:
    Jun 21, 2016
    Posts:
    379
    More out of desperation than anything, I deleted and re-imported the extension and that did not resolve the issue.
     
  5. Ali Al - Mosawi

    Ali Al - Mosawi Member

    Joined:
    Jun 20, 2016
    Posts:
    50
    Yes i get more error in slayer upgrade with GMS 2.2.3
    It was ran in previous version but i dont remeber the version if gms2 i cant countinue with my project
    We have only one way we need to contact with developer
     
  6. zircher

    zircher Member

    Joined:
    Jun 21, 2016
    Posts:
    379
    I posted in his profile with a cross link to this thread, but the dev has not been on for a few weeks. Will just have to exercise some patience, I guess.
     
  7. zircher

    zircher Member

    Joined:
    Jun 21, 2016
    Posts:
    379
    Update: I found a post where slayer 64 was complaining about semicolons in code and stricter syntax checking in 1.4.9999. This may be the smoking gun. I started up a conversation with the author to see what can be done about this specific issue.
     
  8. Ali Al - Mosawi

    Ali Al - Mosawi Member

    Joined:
    Jun 20, 2016
    Posts:
    50
    Thats nice we waiting the response
     
  9. zircher

    zircher Member

    Joined:
    Jun 21, 2016
    Posts:
    379
    Okay, I got it working. I didn't know that we could edit the everything.gml file. I made a back up copy and then went in and added semicolons to all the FOR loops. A little tedious, but the edited file compiled just fine and the game launch. Victory!
     
    Ali Al - Mosawi and slayer 64 like this.
  10. Ali Al - Mosawi

    Ali Al - Mosawi Member

    Joined:
    Jun 20, 2016
    Posts:
    50
    Thats good news i will replace it
    Thank you for all
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice