• Hey! Guest! The 39th GMC Jam will take place between November 26th, 12:00 UTC and November 30th, 12:00 UTC. Why not join in! Click here to find out more!
  • Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Android [SOLVED] Problems with android build - help!

gumbosoup

Member
Hi, I've been trying to compile my game to android and it keeps giving me this error log

  • What went wrong: Execution failed for task ':com.gumbosoup.colorsnakesmash:processDebugResources'.

    Android resource linking failed W:\com.gumbosoup.colorsnakesmash\src\main\res\layout\download.xml:13: AAPT: error: resource string/banner_desc (aka com.gumbosoup.colorsnakesmash:string/banner_desc) not found.

    W:\com.gumbosoup.colorsnakesmash\src\main\res\layout\download.xml:116: AAPT: error: resource string/text_button_pause (aka com.gumbosoup.colorsnakesmash:string/text_button_pause) not found.

    W:\com.gumbosoup.colorsnakesmash\src\main\res\layout\download.xml:130: AAPT: error: resource string/text_button_cancel (aka com.gumbosoup.colorsnakesmash:string/text_button_cancel) not found.

    W:\com.gumbosoup.colorsnakesmash\src\main\res\layout\download.xml:156: AAPT: error: resource string/text_paused_cellular (aka com.gumbosoup.colorsnakesmash:string/text_paused_cellular) not found.

    W:\com.gumbosoup.colorsnakesmash\src\main\res\layout\download.xml:163: AAPT: error: resource string/text_paused_cellular_2 (aka com.gumbosoup.colorsnakesmash:string/text_paused_cellular_2) not found.

    W:\com.gumbosoup.colorsnakesmash\src\main\res\layout\download.xml:176: AAPT: error: resource string/text_button_resume_cellular (aka com.gumbosoup.colorsnakesmash:string/text_button_resume_cellular) not found.

    W:\com.gumbosoup.colorsnakesmash\src\main\res\layout\download.xml:184: AAPT: error: resource string/text_button_wifi_settings (aka com.gumbosoup.colorsnakesmash:string/text_button_wifi_settings) not found.

    error: failed linking file resources.
I'm at my wits end. I've reinstalled Android Visual Studio, updated everything everywhere, am using the latest version of GMS2... And this keeps happening.

The only thing that comes to my mind is that I've followed the instructions on yoyo site closely but what I see in Android Studio does not exactly match their guide. For example there is no option anywhere to download support repositories and so on. I tried everything, three versions of NDK (20 and two 21s) changed SDK from 29 to 28, reduced minimum SDK to 28... everything, the damn thing simply refuses to build for android.

Btw, using GMS2 2.2.5.378 and Android Studio 3.5.3. on win10. Help!
 

gumbosoup

Member
SOLVED!!!

It seems the problem was that I keep my project folder nested deeply on my Google Drive (I move a lot). When I moved the whole thing to the root of my PC the compile worked! I couldn't easily come to this solution (spent a whole day messing with it) because I usually build to win during development and that goes off smoothly from google drive.

I leave this here to help strangers in need.
 
Top