• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Question - Code [SOLVED?] load_csv() crash runner.exe?

Johan Vinet

Hi there!

My proto is crashing and this is the error I got:

"C:\ProgramData/GameMakerStudio2/Cache/runtimes\runtime- exited with non-zero status (-1073741819)
elapsed time 00:00:29.1159824s for command "C:\ProgramData/GameMakerStudio2/Cache/runtimes\runtime-" -options="C:\Users\lordy\AppData\Local\Temp\GameMakerStudio2\build.bff" -- Windows Run started at 2017-01-18 22:14:13"

Some context:
Room1 (my menu), a CVS is loaded with all the parameters for each level of the game. Grid is perfect: you pick a level, press a button (I destroy the ds_grid), go to the level (Room2) with all the good parameters, everything is fine.
Then you die/win, go back to the Menu (Room1), the CSV is reloaded. But, when you pick a level and press the button again, the game crash without even going to the other room.

When I remove this particular CSV importation and assign arbitrary values to the levels parameters, everything is fine. That's why I thought it could be related to this CSV or to the load_csv() function.
Curious thing is: I'm still importing a bigger CSV elsewhere in the game (for randomly generating my levels playfield) and it never crashed the game.

I'd appreciate any help ! Thx ! ;)

Johan Vinet

Not sure why it worked, but I kinda solved it.

I made my "LevelsSettings_grid" (the one made by loading the CSV) a "global.LevelsSettings_grid" and created it in a previous room (the "titlescreen" room).

- I never destroy it (not that big anyway).
- Don't like solving something not understanding why it wasn't working in the first place.

- No crashes anymore.


Previously, in the LevelSettings_grid's destroy - were you deleting the ds_grid?
Not that should cause this issue, it'd just be a memory leak... but its one thing I can think of that'd be different.


That's actually what I meant to say - but no, that's it. I was just double checking. I too am just curious why it was crashing. The only other idea is a stale filehandle, and trying to open the same file multiple times, but I feel that's probably not happening either.

Wondering if there's a bug that needs to filing somewhere is all!


Still experiencing this error. Filled bug report.
Here is the video:
error is random - sometims it works, sometimes - not.


You should minify project to only CSV functions and destroying grid, to be sure that's not the other part of game causing issue. Because - maybe it is.


Out of curiosity, could @Yury and @Johan Vinet try using a custom CSV import script to see if that fixes the problem? LINK

It'd also be useful to see the actual CSV files that are causing problems too - Could you upload them? There's likely a common cause for failure. Additionally, what program did you use to export your CSV files? (GoogleDocs, Excel, LibreOffice etc)