• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows [SOLVED] Issue importing spine sprites

benway

Member
Hello!

I'm not able to correctly import a sprite created by spine on GMS 2.0.5

I import the .json file, but what I see both in the "preview" and in the sprite when I run the project is a strange mess of the sprite parts...

... Nevertheless, the same json (and atlas) work PERFECTLY on GMS 1.4

Any idea?
 

rIKmAN

Member
Hello!

I'm not able to correctly import a sprite created by spine on GMS 2.0.5

I import the .json file, but what I see both in the "preview" and in the sprite when I run the project is a strange mess of the sprite parts...

... Nevertheless, the same json (and atlas) work PERFECTLY on GMS 1.4

Any idea?
What version of Spine are you using, and what version of GMS 1.4?
 

benway

Member
What version of Spine are you using, and what version of GMS 1.4?
Hello, rlKmAN. I'm using spine 3.5.51.

I've tried to remove completely the previous spine installation, and make a fresh install, but still not working on GMS 2.0
 

benway

Member
From what Russell wrote in some previous topic, they support up to 3.4.02
Thank you, gnysek!

How can I downgrade Spine version? If I download it from my personal license page, I obtain the latest version.

And... anybody knows why it does work with GMS 1.4?
 

rIKmAN

Member
Thank you, gnysek!

How can I downgrade Spine version? If I download it from my personal license page, I obtain the latest version.

And... anybody knows why it does work with GMS 1.4?
Load Spine
Go to File > Settings
Under 'Version' click 'Other'
Type in "3.4.02"
Save

Once you restart Spine it will download 3.4.02 and you will be on the version recommended to be used with GameMaker.

As for it working with 1.4, maybe less checking is going on, maybe it's such a simple animation that your json doesn't contain any unsupported data etc it's hard to say, but the recommended / officially supported version is 3.4.02.
 
A

Adrenalite Studios

Guest
Im having the same issue, except im using 3.4.02. Is there a certain preference to export settings from Spine? A max file size?
Im going to try a couple of different things when I get home tonight, but if there was any other info that would be super. Thanks.
 
Top