• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Legacy GM [SOLVED] Invalid at the top of the document error

rIKmAN

Member
Found this error occurred a while ago for other users as well.

https://forum.yoyogames.com/index.php?threads/invalid-at-the-top-level-of-the-document.51945/

I tried this on v1.4.9999 and this error seems top pop up when trying to log in. Tried it on an older version for which I had installer prior to this (v1.4.1773) and the same thing happens. The engine won't start and get stuck in trying to verify the licence after the error. What do I do?
It sounds like you aren't using 1.4.9999.

I know you said you tested 1.4.9999 but I just tested here and it opens without an issue - older versions will have this happen as they still try to connect to News Feed and servers but 1.4.9999 removed these checks and specifically mentioned this in the release notes.
  • Removal of Online Connectivity in the IDE
    • The News feed has been disabled (also stops the script errors shown on startup in previous versions)
    • Links to the Marketplace and for managing your YoYo Account have been removed - please use your browser to do this now
Source: https://store.yoyogames.com/downloads/gm-studio/release-notes-studio.html
 

XirmiX

Member
It sounds like you aren't using 1.4.9999.

I know you said you tested 1.4.9999 but I just tested here and it opens without an issue - older versions will have this happen as they still try to connect to News Feed and servers but 1.4.9999 removed these checks and specifically mentioned this in the release notes.

Source: https://store.yoyogames.com/downloads/gm-studio/release-notes-studio.html
So, what do I do then? I DID install this version, though linked from a different site (hope this isn't a cracked one, sometimes hard to differentiate between that and a site that simply redirects to official downloads). If this is not the real 1.4.9999 version, then where can I get the installer from? I have an account and was given a key (not pro or anything like that, but still) but as I said, am given an error on both versions I tried to log in from.
 

rIKmAN

Member
So, what do I do then? I DID install this version, though linked from a different site (hope this isn't a cracked one, sometimes hard to differentiate between that and a site that simply redirects to official downloads). If this is not the real 1.4.9999 version, then where can I get the installer from? I have an account and was given a key (not pro or anything like that, but still) but as I said, am given an error on both versions I tried to log in from.
Given that the large text at the top of that page you linked says "GameMaker: Studio: 1.4.1763" then I would take a guess and say that it isn't 1.4.9999.

This can be confirmed by attempting to download it and seeing that the file you download is named "gmstudio-installer-1.4.1763.exe".

Download 1.4.9999 from official sources by using the link to the Release Notes I posted in my last post or by logging into your account on the YYG website and downloading it from there.
 

XirmiX

Member
Given that the large text at the top of that page you linked says "GameMaker: Studio: 1.4.1763" then I would take a guess and say that it isn't 1.4.9999.

This can be confirmed by attempting to download it and seeing that the file you download is named "gmstudio-installer-1.4.1763.exe".

Download 1.4.9999 from official sources by using the link to the Release Notes I posted in my last post or by logging into your account on the YYG website and downloading it from there.
I downloaded the installer from the link you gave me, installed it, still had the error, uninstalled it and installed it again in case something may have been left over from the previous version, still getting the same error. I then tried to delete every trace of it, including from the HDD drive that I had installed it on prior with the other version, and it STILL gave me this error.

And regardless, does this mean that all of the older versions of GMS are not going to work at all?
 

Joe Ellis

Member
My version works but it's cus I bought it when it was still supported, and I activated the license, I don't think it's possible to do now. That's for the pro version anyway, I'm not sure about the standard version
 

XirmiX

Member
I contacted Yoyo Games, and was told that GMS 1.4 is no longer supported. I can understand that, but how can a validation error like this be left around? I cannot use GMS 1.4 at all, even with a valid account and license. At this point it's just spamware, sitting on my computer impossible to use, this is nonsense.

EDIT: I was lucky enough to find the license key I had from before, and rather than logging in, using that would enable GMS features. Guess logging is no longer valid for access at all.
 
Last edited:
Top