1. Hey! Guest! The 35th GMC Jam will take place between November 28th, 12:00 UTC - December 2nd, 12:00 UTC. Why not join in! Click here to find out more!
    Dismiss Notice

GM:S 1.4 [SOLVED] Graphical glitch with Intel GPUs?

Discussion in 'Legacy GameMaker Community Tech Support' started by wltr3565, Sep 15, 2017.

  1. wltr3565

    wltr3565 Member

    Joined:
    Sep 15, 2017
    Posts:
    3
    This problem occurs when playing the game with a integrated Intel GPU especially in the likes of laptops that has dual GPUs.
    upload_2017-9-15_10-45-54.png

    When playing the game, it became glitfchy like this:
    upload_2017-9-15_10-48-45.png
    It is unclear if this is just the Intel GPU being upset or is there anything wrong with the loading process. Is there any way to make the game not glitched like this other than having the user change their GPU to an appropriate one?

    Thanks in advance.
     
  2. Mick

    Mick Member

    Joined:
    Jun 30, 2016
    Posts:
    726
    What is your texture page size? Maybe it's too big for the GPU? You could also try changing the vertex buffer method to most compatible or enabling create texture pages on demand. All these settings can be found under Global game settings / Windows / Graphics.
     
  3. rwkay

    rwkay YoYo Games Staff YYG Staff

    Joined:
    Apr 12, 2016
    Posts:
    1,049
    I suspect display drivers myself.... check they are up to date.

    We had a lot of problems with DX9 drivers from Intel in the past on GMS1 - hopefully DX11 will be better.

    Russell
     
  4. wltr3565

    wltr3565 Member

    Joined:
    Sep 15, 2017
    Posts:
    3
    Tested the game with lowest Texture size possible... doesn't work. Most Compatible setting does the same result as well: nothing.

    We did update the driver and... the result is interesting. The glitch still exists, as seen as in this video.

    But the symptom do get eliminated after another graphic load. Even so, we want to minimize the need for our user to tinker their PC even if it's just updating their Intel GPU as much as possible.

    If there's no way around this to make this glitch not happen for even a frame, is there any way to have the game force to use the user's other GPU other than their Intel Integrated Graphics, regardless of their settings? Or is there any loading techniques that can entirely eliminate this glitch? I mean, this glitch occurs even when only the option screen is accessed.
     
  5. FredFredrickson

    FredFredrickson Member GMC Elder

    Joined:
    Jun 21, 2016
    Posts:
    118
    I don't know about other Windows versions, but in Windows 10, you can set GPU affinity on systems that use multiple GPU's... but that's something that the user has to do, on a per-app basis.
     
  6. wltr3565

    wltr3565 Member

    Joined:
    Sep 15, 2017
    Posts:
    3
    Thanks for the support, guys. I have referred to this old thread:
    https://forum.yoyogames.com/index.php?threads/texture-pages-bug.8051/
    And yes, the game doesn't flicker anymore with Intel GPU. Phew.

    But I recall turning this option off will make some PCs actually can't play the game... This needs further testing.

    At least, this problem is solved for now. Once again, thank you.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice