• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Android [SOLVED] Game runs slow on Android, only in GMS2

Appsurd

Member
A few months ago, I decided to move to GMS2. Porting all projects was relatively easy, however, apps are not running smoothly anymore on my Android phone (Samsung Galaxy A8). I have tried to optimize the game as much as possible, e.g. by removing all compatibility scripts and implementing the functionality myself. Using GMS1, all apps ran with 60 fps but now, it hangs around 45-52.

Since I had no idea what was going wrong, I decided to use the profiler. All numbers looked pretty okay to me. Thereafter a created an empty project, with just 1 room and 1 object. This object draws a sprite as background (1080x1920). After compiling this project, it showed the exact same behaviour: the fps drops to 45-52. The strange thing is that friends of mine with comparable phones, can run the game smoothly with 59-60 fps. I know some Android decides have a maximum framerate (and for some, this is 45). My phone probably doesn't, because I sometimes exceed 45 fps and projects from GMS1 did run smoothly with 60 fps.

Besides these things, I tried several other stuff:
I have no idea what causes this behaviour nor how I can fix this. It remains peculiar that the game runs smooth on (most?) other devices and it ran smooth using GMS1. Can anyone help me out?

Tested this using IDE v2.2.3.436 and Runtime v2.2.3.344
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
Moderator
Okay, the fact that the 1.4 games run at full speed would lead me to believe it could be related to two things: the fact that GMS2 uses OpenGL ES2 (while 1.4 uses OpenGL ES1), and a powersaving option on your device, that affects OpenGL ES2 games (but not ES1 games). ES1 games use less power so any power saving features may not kick in with them, so you you probably want to go through your device options and see if there is anything that you can disable related to power saving. I know my older Samsung Galaxy II phone would limit all my projects to about 45FPS...

EDIT: Here's probably where you want to look: https://www.helpforsmartphone.com/p...ides/14/Extend-battery-life-Samsung-Galaxy-A8
 

Appsurd

Member
Thanks for the reply @Nocturne
I went for a search in the settings of my phone, and the issue was not power-saving related, but had to do with a "developer" setting I had been playing with. Nevertheless thanks for your suggestion, it got me into the right direction to "solve" the issue!
 
Top