GML [Solved] Can't connect to (new type) IP address?

XirmiX

Member
I have set up a network connection. The game runs when setting IP adress to the one that the server is running on, but when running the client and entering the.

The new IP address format is what I'm getting, but the old format is indicated as something that doesn't work either. Is there some place where I can check my IP address in a format that is going to work with GML? Because I have tried the new IP, the old IP, both normal and Proxy format, whatever that means, as indicated here: https://www.iplocation.net/find-ip-address

And the new format I see from here: https://whatismyipaddress.com/ip

But NONE work! I have tried this in different places where the format for the IP address looks close to the one under "Proxy" as the second address, and I didn't have the new IP format, and it worked, but now with the new IP format, I have connection problems :(

My internal IP address, which is the old format, but the first on the list of Proxy starts with the number 5 btw.
 
E

evenprimes

Guest
Do you have a router or a modem/router combo? If you're running the client and server on two computers attached to the same router, you need to use their local IP addresses, which are different from the public IP address of your network (which you see at the websites you linked).

To find your local IP address, open a command window (varies by OS) and type "ipconfig" (for Windows) or "ifconfig" (for Linux/Mac). Among the output you should find your local IP address, which is typically something like 192.168.1.7.

If you're running the client and server on the same computer, try 127.0.0.1 -- the 'loopback' address.

If you're running the client and server on two completely different networks, but one or both of those networks use routers, you might want to research port forwarding.
 

The-any-Key

Member
Can you draw up the network for us. So we get a better understanding of the way between the endpoints.
Do you go via internet? From a school/work computer via internet to a computer at home? What is the setup?
Ex:
 

XirmiX

Member
I used uni's wifi, which I have no idea where the router would be for my accommodation. I actually found out what the v4 IP address was by typing in "ipconfig" in the command prompt (for Mac users it would be "ifconfig" instead). This IP address was not detected by google or any site at all, but I was able to use the IP address that I had not seen before in order to make the connection. So, in essence, if you're having problems connecting, ask the command prompt :p

EDIT: The IP address keeps changing over time, so I'm guessing every time there are wifi issues, they switch routers, something to keep in mind when networking!
 
Last edited:
Top