1. Hey! Guest! The 36th GMC Jam will take place between February 27th, 12:00 UTC - March 2nd, 12:00 UTC. Why not join in! Click here to find out more!
    Dismiss Notice

Question - Code [SOLVED] Built-in functions seem to have vanished!

Discussion in 'GameMaker Studio 2 Community Tech Support' started by KMVegas, Feb 4, 2020.

  1. KMVegas

    KMVegas Member

    Joined:
    Aug 11, 2017
    Posts:
    11
    I'm not sure how I managed this one... but a couple of functions are just gone in GMS, specifially the bitmask_set_submask / bitmask_get_submask. I type them, but code completion doesn't recognize them, they are color coded as variables when I type them, and I get "uknown function or script" on them at compile time.

    Some info...
    • I know It's exclusive to a single project. I tested another project, and it's fine.
    • I've tried deleting caches that I'm aware of, but no joy yet.
    • I noticed it after trying to type one of the functions before correcting a line of code that the code editor had flagged red.
    • I've tried a few other functions, and they seem to show up fine, so I'm pretty sure it's exclusive to these functions.
    I guess that's all at the moment. I don't know if it's a bug or if I somehow confused Game Maker Studio with something I did. Is there maybe a certain cache or temporary folder I should be looking to delete?

    Thanks for any help!
     
  2. IndianaBones

    IndianaBones Member

    Joined:
    Jul 5, 2016
    Posts:
    2,393
    Those are not built in functions. Must be a script you didn't import or went missing in that project.
     
    Cpaz likes this.
  3. KMVegas

    KMVegas Member

    Joined:
    Aug 11, 2017
    Posts:
    11
    Ugh... I feel so stupid right now lol I'm always over looking the simplest of things, even after almost 20 years. That's exactly the issue. I just started this project last night and I'm gradually copying things over from another project. In the process, I forgot that these functions weren't built in. Thanks for pointing out what I should've seen, buddy.
     
    IndianaBones likes this.

Share This Page