• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

SOLVED [SOLVED] Black Screen on Space Rocks DnD tutorial


Hello Dear cCmmunity,

Full of envy, hope and will, I embarked on the GameMaker Studio 2 adventure.
Knowing that I have no experience in computer code, I started by following the tutorial "My First Game - DnD - Setup & Movement - Space Rocks" put forward on the welcome page to familiarize myself with the beginnings of the software.

I followed the instructions to the letter despite that when I press "F5" a "black screen" appears. By "black screen", I should specify that it is a screen displaying only the "background".

Finally, my objects are invisible during the "run".
I have to admit that this is a big chill on my interest in buying the software during the test period.

I saw that the point had already been discussed on the forum so I checked and tried the different solutions :
  • - my sprites do have the "visible" box checked
  • - my objects in the room are checked
  • - I redid the project several times, starting from scratch.
  • - my layers are in the right order and visible
  • - I told my firewalls and anti-virus software to leave the software alone.

Having repeated the tutorial five times without any result, I ask for your help to understand what is difficult to display objects during their execution.
For my mental health, I would very much like to find out what the problem is.
I took the time to browse the forum before posting this message (avec the tag "space rocks black screen") to see if there wasn't already an answer solving this problem but I would like to apologize in advance if this topic is not in the right place or if there is already an existing topic with the right solution to my situation.

I put some screenshots below.

Thanking you in advance for your help on this beginner's topic !!!!

Screenshot of the "room" with the selected layer:
210117 Room-Instances.JPG

Screenshot of the "Run" :
210117 Run.JPG

Screenshot of a "Sprite":
210117 Spr_ship.JPG

Screenshot of a "object":
2101017 Obj_ship.JPG


šŸ§ *penguin noises*
GMC Elder
There's two things you haven't tried yet that could help:
  • Open the "viewports and cameras" section in the room editor and make sure "use views" is checked and that view 0 is visible.
  • Click the "broom" icon next to the Test Play / Debug icons to clear the compiler cache, then build the game again (if you got all graphics deleted by your antivirus program they won't be rebuilt as long as GM thinks it has a cached version, doing this forces a rebuild of everything whether GM thinks it needs to or not)


Hey Yal !

Thanks for those quick answers !

So I've got:
- check "Enable Viewports" in "viewports and Cameras" & check in "Viewport 0" the "Visible" box.
no result during the run, I always only have the background displayed

-I used the "broom" icon, deleted the "room", recreated a room, reintegrated the "objects" by dragging and dropping them" and applied the "viewports and cameras" parameters.
and still no result only a purple background.

Could the problem come from the sprites themselves ?
Thanks for the time taken for this level 1 mystery :) .

Screenshot of a "viewports and Cameras":
210117 Viewports and Cameras.JPG


šŸ§ *penguin noises*
GMC Elder
Could the problem come from the sprites themselves ?
You're using sprites with 1-pixel lines in a 500x500 room... with the 1280x768 default view size... so it's possible the pixels in the sprites get 0 pixels wide when drawn?


Hello to both of you!

Thank you very much, the problem is solved.

Here is my test path:

1. I added as a specific exception the Igor.exe file to my various protection software and restart the computer (and not only the "GameMaker Studio" folder as initially)
2. I restarted GMS with my file with no result
3. but I didn't give up anything and created a new sprite in 200*200 and associated with a new object in the same project: bingo this new sprite was displayed on my "run"!
4. I went down gradually in size and all the new sprites (associated with new objects) up to 16*16: bingo they were all displayed
5. For my original sprites (ship and asteroid), they continued not to want to be displayed so I deleted the object and recreated a new one and tadaaaa they were displayed in the "run" (without my having to modify or recreate the concerned sprites).

So a big thank you for your patience and time, I hope this topic will help other people!

I can start my small projects and my mental health remains intact :D