• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

GMS 2.3+ [SOLVED] Audio not playing in Breakthrough tutorial Game (please help)

Hello, I'm relatively new to game development and Game maker studio 2. I was recently following the tutorial of FriendlyCosmonaut for the game called "Breakthrough" in GML.

I got my sound assets from downloading it from the tutorial. The game should play a sound when a collision is detected or when an object is created using this function "audio_play_sound(soundid, priority, loops )." For some reason, my sound won't play and it really frustrates me.

Even a past tutorial game that I followed instructions (that I admittedly have not touched in a long time) such as Space Rocks from FriendlyCosmonaut, has its sound not working all of a sudden.

My "Default Audio Device" is at the right settings, and I tried using .Wav or .Ogg with very little success. Running the game won't play sound, as well as making an executable of it.
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
Hello! Did you resolve this issue? My first suggestion would have been to check the Audio Device settings, but you've done that, so I'm not sure what else to say... Have you been able to share the project with other people and see if the sounds play for them? If they don't then you know it's an issue with the project, if they do then you know it's an issue with your PC (or specifically GameMaker on your PC).
 
Hello, so just in case people have an issue like this, I'll post an update to what happened.

So my machine is a laptop, specifically an MSI Laptop product name GL62M 7RC. My operating system is Windows 10 and my audio driver is Realtek High Definition Audio. I suspected the issue to be one with my audio driver as other forums would suggest that the problems lie there. I've tried every solution I could find but to no avail. Updating the audio drivers did not work, and my settings were clearly okay. Installing and uninstalling did nothing for me and any other forum solution found here and other websites offered nothing helpful.

Eventually, I noticed that audio problems would randomly occur towards different programs for no good reason which caused me to strongly suspect that this was an issue with the audio driver (which are all updated). I then noticed a program in the task manager called "Realtek HD Audio Manager". I decided to play around with the program to see if it would do anything as no other forum suggested a solution like this. The program is supposed to start on startup because I have it enabled, however, I have never noticed it actually startup. I started up Realtek HD Audio Manager and then attempted to execute the game through Game Maker Studio 2, to my surprise the sound actually worked! I don't fully understand why, but I figured that this audio manager is crucial to Game Maker Studio 2 for some reason.

I posted this fix here as I wonder if other users have this same problem and if this same problem also applies to other audio drivers. I hope this gives insight to anyone who may face audio problems in the future. Good luck!
 
Hello, so just in case people have an issue like this, I'll post an update to what happened.

So my machine is a laptop, specifically an MSI Laptop product name GL62M 7RC. My operating system is Windows 10 and my audio driver is Realtek High Definition Audio. I suspected the issue to be one with my audio driver as other forums would suggest that the problems lie there. I've tried every solution I could find but to no avail. Updating the audio drivers did not work, and my settings were clearly okay. Installing and uninstalling did nothing for me and any other forum solution found here and other websites offered nothing helpful.

Eventually, I noticed that audio problems would randomly occur towards different programs for no good reason which caused me to strongly suspect that this was an issue with the audio driver (which are all updated). I then noticed a program in the task manager called "Realtek HD Audio Manager". I decided to play around with the program to see if it would do anything as no other forum suggested a solution like this. The program is supposed to start on startup because I have it enabled, however, I have never noticed it actually startup. I started up Realtek HD Audio Manager and then attempted to execute the game through Game Maker Studio 2, to my surprise the sound actually worked! I don't fully understand why, but I figured that this audio manager is crucial to Game Maker Studio 2 for some reason.

I posted this fix here as I wonder if other users have this same problem and if this same problem also applies to other audio drivers. I hope this gives insight to anyone who may face audio problems in the future. Good luck!
UPDATE. After further experimentation, I noticed that the game would play sounds at random, certainly, my actions of playing around with the Realtek HD audio manager program had an impact as it actually played sounds at random whenever I executed the game however it lacked the consistency to it that I figured I needed to find a better solution. Eventually, I just settled to use a USB sound card which then fixed my problem.
 
Top