• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Android [SOLVED] .apk doesn't compiling. Keystore troubles. (GMS 2.3)

Hello, dear members.
Everytime i try to compile an .apk it's always failing to build.

Here's OUTPUT
> Task :com.someone451.app:packageRelease FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':com.someone451.app:packageRelease'.
> 1 exception was raised by workers:
java.lang.RuntimeException: java.lang.RuntimeException: com.android.ide.common.signing.KeytoolException: Failed to read key Alias_def from store "C:\Users\VnD\Documents\GameMakerStudio2\!FireUA\!fireUA 4 1 1\fireUA411.keystore": Keystore was tampered with, or password was incorrect


Also sometimes i see this after build fail.

The JKS keystore uses a proprietary format. It is recommended to migrate to PKCS12 which is an industry standard format using "keytool -importkeystore -srckeystore C:\Users\VnD\Documents\GameMakerStudio2\Android 2.3 test 2\Android 2.3 test 2.keystore -destkeystore C:\Users\VnD\Documents\GameMakerStudio2\Android 2.3 test 2\Android 2.3 test 2.keystore -deststoretype pkcs12".
elapsed time 00:00:00.2460141s for command "C:\Program Files\Java\jdk1.8.0_251\bin/keytool.exe" -exportcert -keystore "C:\Users\VnD\Documents\GameMakerStudio2\Android 2.3 test 2\Android 2.3 test 2.keystore" -alias "Alias" -storepass "tusik1992" -list -v started at 09/23/2020 14:24:56


IDE 2.3.0.529. Runtime 2.3.0.401

Maybe something wrong with my settings?






 
Untitled.png
From what I can tell are that;
  1. You had assigned the JAVA JDK Location to a JRE folder. If you haven't already have the Java JDK in your system (pc), download it from Oracle's website. I'm currently using this version : jdk1.8.0_261 to build my app. There might already be a newer version on that site.
  2. I'm not sure if it's possible to compile into apk/aab, without first pressing show key hash -> apply, before pressing create executable. I personally have this habit of doing so.
FYI, you didn't censor your keystore data properly, I can still make out what you washed out.
 
Last edited:
Problem solved!

So i did some changes here
001.png
And (i think it's most important part) i went to directoty
"C:\ProgramData\GameMakerStudio2\Cache\runtimes\runtime-2.3.0.401\android\runner\gradle\gradle\wrapper\"
and edited "gradle-wrapper.properties" file in wordpad.
I changed the line "distributionUrl=https\://services.gradle.org/distributions/gradle-5.1.1-all.zip"
to this one
"distributionUrl=https\://services.gradle.org/distributions/gradle-5.4.1-all.zip"
 

heriol18

Member
I already did everything :( this error has me crazy: Keystore was tampered with, or password was incorrect

Already install the distributionUrl = https \: //services.gradle.org/distributions/gradle-5.4.1-all.zip and change the JDK, in the Configuration by giving "show hash" it loads fine and says the key is correct , but when compiling it appears that it does not match :(
 
Top