1. Hey! Guest! The 32nd GMC Jam will take place between Feb 22nd, 12:00 UTC (Friday noon) and Feb 25th, 12:00 UTC (Monday noon). Why not join in! Click here to find out more!
    Dismiss Notice

Shader issue.

Discussion in 'Programming' started by denizdeni, Jan 18, 2019.

  1. denizdeni

    denizdeni Member

    Joined:
    Jun 5, 2018
    Posts:
    1
    my code on Draw Gui:
    Code:
    if(waveydraw) {
    var_time_var += 0.04
    shader_set(shd_wave);
    shader_set_uniform_f(shader_get_uniform(shd_wave,"time"), var_time_var);
    shader_set_uniform_f(shader_get_uniform(shd_wave,"mouse_pos"), 0, 0);
    shader_set_uniform_f(shader_get_uniform(shd_wave,"resolution"),  __view_get( e__VW.WView, 0 ),  __view_get( e__VW.HView, 0 ));
    shader_set_uniform_f(shader_get_uniform(shd_wave,"wave_amount"), 5);
    shader_set_uniform_f(shader_get_uniform(shd_wave,"wave_distortion"), 80 );
    shader_set_uniform_f(shader_get_uniform(shd_wave,"wave_speed"), 2);
    application_surface_draw_enable(false)
    better_scaling_draw_surface(application_surface,0,0,1,1, 0, all, 255, true)
    shader_reset();
    }
    Normally, it's looking like

    [​IMG]

    If i set waveydraw to true it's looking like this.

    [​IMG]

    why????
     
  2. TsukaYuriko

    TsukaYuriko Q&A Spawn Camper Forum Staff Moderator

    Joined:
    Apr 21, 2016
    Posts:
    991
    For the sake of context, what are you expecting to happen instead? Please always include your expected scenario so that we can know how what's going on differs from what's intended. Undocumented code and two screenshots don't exactly form a solid basis to diagnose problems on.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice