Screen Tearing

baconlovar

Member
Hey everyone, about 4 months ago I started a project I am about to finish. 4 months ago I had a monitor that was 1366 x 768. So, mistakenly, I made all my views, view_in_room, and ports the exact same as my screen resolution.

Later, I got a new monitor that is 1920 x 1080.

I noticed that when I go fullscreen, the screen tears pretty badly. I tried fixing it by changing the port and view_in_room to 1280 x 720 (true aspect ratio), and a few others, but it still tears awfully.

Any suggestions? Do I need to change the room size while using views??
 

Simon Gust

Member
Hi, there are two ways:
either turn on Use Synchronization To Avoid Tearing in the game Settings
or
Use fake Fullscreen, turn Fullscreen off but leave the viewports at the Monitor Resolution (might not work though)
 

RangerX

Member
Try the solution from Simon and if you still get graphical deformation it means its scaling problem (which I suspect you're mixing with tearing)
 
Top