• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows Runtime issue? Can't build using Runtime; Windows Defender detects virus


Hello all.

First of all, a quick disclaimer that this issue is very much over my head, so apologies if my description of this issue comes off ignorant in any way.

I just got done working through the "Little Town" tutorial, and full of pride and excitement decided to go ahead and export a .zip file of the "completed" game.

Upon attempting to build the .zip, my Windows Defender threw out a quick error stating that it had found "Trojan:Script/Phonzy.A!ml". Details pointed to the .exe of the game located in the AppData/Local/GameMakerStudio2/GMS2TEMP folder.

The console output in GMS2 notes: "Exception during processing System.IO.IOException: Operation did not complete successfully because the file contains a virus or potentially unwanted software."

These messages came up even when building a new, empty project.

Obviously, for a programming noob like myself this was pretty scary to see and immediately made me worry that I have some heretofore undiscovered infection. However, after some exploration on these forums and elsewhere I read a tip about changing runtimes, and sure enough, once I backed up my runtime to, this issue went away and I could build both .zip files and .exe installers, without any obvious errors or virus concerns.

So with all that said, I'm hoping this indicates that for some reason runtime is causing some sort of false positive? But I have no idea why, or if there is something specifically wrong with my PC, or what I could do to get around it.

For the meantime, I will stick with .442, and hope that this magically fixes itself whenever the next runtime/update is released.

With that said, any thoughts or suggestions would be very much welcome, as again, this is totally above my paygrade - I just want to make small dumb games :)


Hey - coming here after a similar experience, but this issue seems to have persisted into the next runtime, 458.
Any potential ideas or fixes @Yoyogames staff?


Quick update:

Just updated my version of GMS2 to IDE and Runtime

I am now able to create executables (zip and installer) - most of the time.

Every now and again I do still get an error: "Permission Error : Unable to obtain permission to execute" There does not seem to be a clear pattern or trigger for when this happens. I have tried building with the same project over and over, without changing a thing, and eventually it will just work.

All of these tests were done with a new project with a single empty room.

Thankfully, in every case, my Windows Defender did not throw a false positive detection of a trojan virus... so that's at least a step in the right direction!

Still not an ideal situation, but definitely a lot more workable than what I had with Runtime