• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Legacy GM Runner Fails to Open



When I press the green button/f5, the runner never pops up. When I run debug, the runner crashes. I have not successfully run my game yet. It fails to work on an empty project as well.

I am running Windows 10, 8GB RAM, with Nvidia 940MX Graphics with 2GB of VRAM. I have DirectX 12.
GM:Studio Version 1.4.1760

Things I have tried:

-Restarting Computer (several times)
-Reinstalling GM
-Rolling GM back to a different version
-Updating DirectX
-Update my graphics drivers
-Make a new project
-Export project and run separately
-Browsing and googling for several hours

Nothing appears to be working thus far.

I have narrowed down the problem to some sort of issue with the runner.

What normally happens is I rujn the game, it compiles without error, then says the compile is complete. However, no runner pops up, nor is running in the background.

When I run my game in debug mode, the runner briefly pops up, but encounters a crash and stops.

Any help is appreciated, and please don't hesitate to ask for more information.

The compiler when I attempt to launch the game.

Create Score Form
Create Load Form
Create Error Form
Do The Work
initialise everything!
Process Chunk: GEN8 136
Process Chunk: OPTN 64
Process Chunk: LANG 12
Process Chunk: EXTN 4
Process Chunk: SOND 4
Process Chunk: AGRP 4
Process Chunk: SPRT 2156
Process Chunk: BGND 4
Process Chunk: PATH 4
Process Chunk: SCPT 4
Process Chunk: GLOB 4
Process Chunk: SHDR 4
Process Chunk: FONT 516
Process Chunk: TMLN 4
Process Chunk: OBJT 1100
Process Chunk: ROOM 1544
Process Chunk: DAFL 0
Process Chunk: TPAG 136
Process Chunk: CODE 1596
Process Chunk: VARI 372
Process Chunk: FUNC 208
Process Chunk: STRG 900
Process Chunk: TXTR 4960
Process Chunk: AUDO 4
Preparing 4 objects:
Objects 0: obj_player
Objects 1: obj_asteroid
Objects 2: object2
Objects 3: obj_handler
Finished PrepareGame()
Total memory used = 311283(0x0004bff3) bytes
Entering main loop.
Compile finished: 9:58:36 PM