Linux Run the GMS2 IDE on Ubuntu 19.04

KaiDev

Member
@gnysek

Dude... that is an awesome find. I didn't realize they had even gotten that far with Linux, which is odd considering the constant 'not worth the cost of development' bits. Just, um, out of curiosity, did you do anything special to log in via the Linux version? I keep getting an 'Error (50)', even re-using my cached login data from a WINE prefix (albeit I'm on Manjaro instead of Ubuntu so plenty of other ways things could go wrong). If not I'll just have to figure it out.

I've been making due w/ GMEdit and a bash script that compiles / runs things for me. But I have to open GMS through WINE to add any extensions or change build properties (which is INSANELY slow for large projects). I would love to be able to have a native IDE just for editing those bits.
I managed to get passed that issue, it was because it looks for Windows or Linux on the login server and because it would of came up with something different, it won't let you login. If you want me to upload the file, I can if people need it.
 

gnysek

Member
If you want me to upload the file, I can if people need it.
I would suggest not, as there's thin line to break EULA here. But yes, this error is because during getting license details from licensing server, one of param says from which OS IDE runs (so here's it's linux) and none of commercial licenses are enabled now to run linux version now (but for sure YYG is able to create special licenses or mark selected user licenses to make it working - same as during closed betas).
I hope they planning to release it this year (maybe they are waiting to change rendering system for IDE first, or that's why they stopped to work in this version, to not fix bugs which might be solved by rendering engine?).
 
Last edited:

Yal

šŸ§ *penguin noises*
GMC Elder
i set that up to connect to 127.0.0.1 but ran into publickey errors even though the connection test went fine. recursively setting 700 for ~/.ssh solved what wasn't working for me.
Just for some context here: having the execute flag set for a folder lets you access it (and things inside it!) from a different folder from its parent, I think that's what happening here (e.g. you can only execute a program in the current working directory unless you also have the execute permission for the folder that contains it, even if the execute flag lets you run it). It also applies to things like listing the folder contents, so if it's not set, things like the * matching could fail.

So TLDR, constructions like
./myfolder/thatotherfolder/thing.sh
would fail unless you set the +x flag and that's probably what's happening here
 

GMS2onlnx

Member
I was able to install gms2 on kubuntu. It run flawless when installed but when I restarted It shows nothing. I've got some messages at konsole.
Initial process has started with pid 6467
Start monitoring process.
Starting......
Doing Validate Folder check... macOS=False
************************************** 07/30/2021 **************************************
Log.Initialise
OpenGLCheck : GL_VERSION="4.5 (Compatibility Profile) Mesa 21.3.0-devel (git-d9a4a0a 2021-07-30 focal-oibaf-ppa)" GL_VENDOR="AMD" GL_RENDERER="AMD KAVERI (DRM 2.50.0, 5.4.0-80-generic, LLVM 12.0.1)"
Skin: Z:\home\rodrigo\.wine\drive_c\Program Files\GameMaker Studio 2\GUI\Skins/Dark
GameMakerStudio, Version=2.3.3.574, Culture=neutral, PublicKeyToken=83c29ed24e39e35e
Initialise()
Command line arguments=""
SteamAPI Init returned : False
Loading proxy settings
Checking network....
Initialise(0.0)
Layout Manager: Attempting to register 'YoYoStudio.Sequences.Extensions.CanvasSequence+' from assembly 'IDE'. The gadget name '' is already in use, this may be caused by conflicting plugins
Layout Manager: Attempting to register '.' from assembly 'IDE'. The gadget name '' is already in use, this may be caused by conflicting plugins
Layout Manager: Attempting to register '?.' from assembly 'IDE'. The gadget name '' is already in use, this may be caused by conflicting plugins
Layout Manager: Attempting to register 'YoYoStudio.GUI.Gadgets.RemoteWorker.RemoteWorkerSettings+' from assembly 'IDE'. The gadget name '' is already in use, this may be caused by conflicting plugins
Layout Manager: Attempting to register 'YoYoStudio.GUI.Gadgets.Inspector.InspectorDndPreview+' from assembly 'IDE'. The gadget name '' is already in use, this may be caused by conflicting plugins
Layout Manager: Attempting to register 'YoYoStudio.GUI.Gadgets.Inspector.EventListBox+' from assembly 'IDE'. The gadget name '' is already in use, this may be caused by conflicting plugins
Layout Manager: Attempting to register 'YoYoStudio.GUI.Gadgets.Inspector.MultiSelectListBox+' from assembly 'IDE'. The gadget name '' is already in use, this may be caused by conflicting plugins
Layout Manager: Attempting to register '?.' from assembly 'IDE'. The gadget name '' is already in use, this may be caused by conflicting plugins
Initialise(0.1)
Prefs: Error loading ${system_directory}\org_settings.json
Prefs: file not found
Prefs: Error loading ${system_directory}\machine_settings.json
Prefs: file not found
Initialise(0.2)
Initialise(1)
Initialise(1.1)
Default Device: Pulseaudio
Found Device: Pulseaudio
Initialise(1.2)
Initialise(2)
Initialise(3)
Initialise(4)
Initialise(4.1)
Initialise(4.2)
Initialise(4.3)
Initialise(4.4)
Initialise(4.4.1)
Initialise(4.4.2)
Initialise(4.5)
Check (1)
Check (2)
Initialise(4.6)
Initialise(4.7)
Initialise(4.8)
Initialise(4.9)
Initialise(4.10)
Initialise(4.11)
Initialise(4.12)
Initialise(5)
Initialise(6)
Initialise(7)
Initialise(7.1)
Initialise(8)
Initialise(9)
Initialise(10)
... and when I open Ksysguard Game Maker Studio 2 is there, using 20% from CPU. Any hint on what might be happening?
 
Top