Linux Run the GMS2 IDE on Ubuntu 19.04

benway

Member
@benway Can you try using wayland display manager for a bit?
https://itsfoss.com/switch-xorg-wayland/
If you were already using wayland, try Xorg instead.
Thank you for your answer :)

I was using Xorg, but I've obtained the same result using Wayland (BTW, it took me a while until I found the grub.conf nvidia drm switch trick to turn Wayland work xD)

When I move the mouse on GMS app, I can see a lot of messages of this kind on the terminal window:

Code:
0009:fixme:win:GetMouseMovePointsEx (24 0x52df28 0x52d900 64 1) stub
0009:fixme:win:GetMouseMovePointsEx (24 0x52df28 0x52d900 64 1) stub
0009:fixme:win:GetMouseMovePointsEx (24 0x52df28 0x52d900 64 1) stub
0009:fixme:win:GetMouseMovePointsEx (24 0x52df28 0x52d900 64 1) stub
But there isn't any of them when I move the mouse wheel.

I've tried again with any other app (f.i. firefox installer, and the wheel works fine).

I'm using Ubuntu 19.04, and my mouse is a Rapoo MT750 (with the same results both bluetooth connected and wireless connected)...
 

benway

Member
Another issue I've found: I cannot uninstall GMS (in order to update the IDE). At the start of uninstallation process, it stops, saying that it can't uninstall GMS because GMS is running (although is not running at all) :(
 

Yal

🐧 *penguin noises*
GMC Elder
If you try running ps aux | grep <name of GMS2 executable>, does it show up there as a zombie process or something? Did you have it running normally before engaging the update? Does it work if you reboot and then try updating it?
 

Tthecreator

Your Creator!
Another issue I've found: I cannot uninstall GMS (in order to update the IDE). At the start of uninstallation process, it stops, saying that it can't uninstall GMS because GMS is running (although is not running at all) :(
How did you check the process isn't running. You can use Q4Wine to see which processes are running.
 

benway

Member
If you try running ps aux | grep <name of GMS2 executable>, does it show up there as a zombie process or something? Did you have it running normally before engaging the update? Does it work if you reboot and then try updating it?
There isn't any process running related to GMS (ps aux only returns the grep command, and without the grep and checking one by one every process, there isn't anything related to GMS but the uninstaller itself).

@Tthecreator : The Q4Wine list of processes doesn't show "gamemaker.exe" at all:

uninstaller.png
I can remove gms2 prefix, create it again, and install the current version... but it should work! :)
 

Yal

🐧 *penguin noises*
GMC Elder
Maybe the GMS2 installer detects the wine launcher it's being run in, and assumes it's a GMS2 process since it's got some GMS2 modifier in its data, and isn't the installer process, "so what else should it be"?
 

Tthecreator

Your Creator!
There isn't any process running related to GMS (ps aux only returns the grep command, and without the grep and checking one by one every process, there isn't anything related to GMS but the uninstaller itself).

@Tthecreator : The Q4Wine list of processes doesn't show "gamemaker.exe" at all:

View attachment 26973
I can remove gms2 prefix, create it again, and install the current version... but it should work! :)
Yup this is a real issue... I don't have a solution right now, but I've added it to the original post with credits to you @benway

Maybe the GMS2 installer detects the wine launcher it's being run in, and assumes it's a GMS2 process since it's got some GMS2 modifier in its data, and isn't the installer process, "so what else should it be"?
I'm not sure, I think it actively looks for "GameMakerStudio.exe". Could it be that it's looking for some temp file? I think a very small subset of windows users also have had issues like this: https://forum.yoyogames.com/index.php?threads/gamemakerstudio-exe-is-running.61753/
 
I followed these instructions to get GMS:2 running on the most recent version of Linux using Wine 4.18- thank you very much for figuring this out for all of us! However, I noticed that the shortcut GameMaker automatically adds to the Unity Launcher [the lower-left pop-up menu] will not let GameMaker compile games for testing, and that the only way to let it do so was to run the command you provided. I did not like this extra step, so I figured out a way to fix the default .desktop file that the Unity Launcher shortcut works off of to run the command automatically!

1] Create a new, blank document on the Desktop [or anywhere you wish, really].
2] Copy and paste this into it:

WINEPREFIX=~/gms2 WINEARCH="win64" wine64 "/home/<YOUR USERNAME>/gms2/drive_c/Program Files/GameMaker Studio 2/GameMakerStudio.exe"

3] Save the file as "GameMaker Studio 2.sh".
4] Open Nautilus [Files], press CTRL-L, and copy-paste into the address bar:

~/.local/share/applications/wine/Programs/GameMaker Studio 2

5] Open "GameMaker Studio 2.desktop", and replace everything in it with this:

[Desktop Entry]
Name=GameMaker Studio 2
Type=Application
Exec="/home/<YOUR USERNAME>/Desktop/GameMaker Studio 2.sh"
Icon=470F_GameMakerStudio.0
Terminal=true
Categories=Programming;Application;

6] Repeat step 5 for "GameMaker Studio 2 License.desktop".
7] Click the GameMaker Studio 2 icon in Unity Launcher. A Terminal window should open, followed by GameMaker, and you should be able to compile games as well as export them with no issue!
 
That said, I am having a problem that I cannot seem to resolve, that being that the fonts in the GameMaker IDE are not showing up correctly. I followed the instructions in the post to install all of Windows' fonts using WineTricks, making sure that I installed them to the correct Wine prefix, and even finding them in the directory to ensure that they are indeed there, but GameMaker will not use them for whatever reason. The Font Editor within the IDE can and will select from the installed Windows fonts, indicating that it can find them, and the IDE Environment Variables window shows as having the correct path to the Fonts folder, but the IDE will not use them. Any ideas?
 
This is working generally great for me on pop-Os. I'm however having one problem where the touch pad scrolling doesn't work at all inside the IDE. It works everywhere else. Has anyone else experienced this?
laptop model: xps 15 9560.
 

DarthTenebris

Definitely not a Sith Lord
So I made a Linux Live ISO disk image that can be burned to a DVD-R with at least 4.7 GB of capacity, and then you may boot from that DVD into a temporary Linux session. See the readme.txt spoiler for more details, but it will make porting your game to Linux super easy if you don't have a Linux machine and don't really care to ever permanently install a Linux distro on your machine.








Thank you for downloading krapOS!

Before you begin using krapOS, there are a few things to make note of.

1) krapOS is a temporary session, meaning all data on it will be wiped and reset to all of its default files and settings upon shutdown and reboot. To avoid losing your work, back it up on removable media or upload the related files to an online backup service such as Google Drive or Dropbox. krapOS does not install anything on your computer, it does not modify any files on your computer, nor does it leave anything behind on your computer. It is 100% non-destructive to your computer and its data.

2) krapOS is based on KDE neon 5.16 User Edition, which is based on Ubuntu 18.04 LTS Bionic Beaver. As such, software you download must be compatible with this version of Ubuntu which krapOS is based on. (GameMaker Studio 2 games 'just work').

3) Microsoft Windows software will generally work out-of-the-box thanks to the software known as Wine. You may use Wine to run Windows programs with minimal hassle. Not all Windows software are compatible with Wine, so you don't technically know whether a specific application will work without testing it first. Try it! GameMaker Studio 2 can even be run under Wine. Check out this post: https://forum.yoyogames.com/index.php?threads/run-the-gms2-ide-on-ubuntu-19-04.64330/#post-405199

4) After krapOS has finished booting up, you will notice a shortcut icon on the desktop that is labeled "Install krapOS". DO NOT open this file! I created this shortcut for testing purposes only, in attempt to make an option for the user to permanently install krapOS on their system, if they wanted to. Sadly, it does not work; it is guaranteed to crash in the middle of installation, after it has already created a partition for krapOS on your system, therefore greatly limiting the space on your filesystem. As long as you avoid running this installer entirely, your computer will be fine.

<krapOS Login>
rootuser: owner
password: password

Have fun!
- Samuel Venable

[Download krapOS]

To install GameMaker Studio 2 on krapOS, you may skip all the dependency installation steps in the OP, i.e., start here instead:
Any chance you can make krapOS something permanent? I'd like to have it on a flashdisk, along with any work I would be doing. Also, seeing krapOS is based on Ubuntu 18.04, what are the chances the files GMS produces will also run on later versions of Ubuntu?

Thank you for your time.
 

Yal

🐧 *penguin noises*
GMC Elder
This is working generally great for me on pop-Os. I'm however having one problem where the touch pad scrolling doesn't work at all inside the IDE. It works everywhere else. Has anyone else experienced this?
laptop model: xps 15 9560.
Have you tried turning off/on Laptop Mode? It changes the way scrolling works to make touchpad scrolling smoother (forcing you to press down certain keys to scroll so that you won't do it accidentally, iirc - I don't use it myself), and this will by default be set automatically depending on whether you're running on a laptop or not.

Any chance you can make krapOS something permanent? I'd like to have it on a flashdisk, along with any work I would be doing. Also, seeing krapOS is based on Ubuntu 18.04, what are the chances the files GMS produces will also run on later versions of Ubuntu?

Thank you for your time.
Very high chances. I use 16.10 at work (14.10 was supposedly needed for compatibility reasons with the build environment but everybody uses 16 instead) and I've got no problem running both bleeding-edge programs designed for the latest Ubuntu and programs compiled in the late 1990s.

You could be interested in following this discussion, though: https://forum.yoyogames.com/index.php?threads/game-doesnt-launch-when-uploaded-to-steam-needs-libraries.70258/#post-416778
(About how to include needed library versions with your game to make it launch properly independently of which version is installed locally)
 
Have you tried turning off/on Laptop Mode? It changes the way scrolling works to make touchpad scrolling smoother (forcing you to press down certain keys to scroll so that you won't do it accidentally, iirc - I don't use it myself), and this will by default be set automatically depending on whether you're running on a laptop or not.
Yup, I've tried that. Unfortunately didn't help. I just noticed that the scrolling doesn't work with an external mouse either. It works fine on the same computer while booted into windows and running gms2 tho.
 
Runs great though scrolling and zooming of any kind does not work in my experience which makes the interface extremely difficult to navigate.
 

Yal

🐧 *penguin noises*
GMC Elder
Does using Ctrl + T to quickly jump to a resource help alleviate those issues? It automatically switches focus to an open window if there is any, otherwise opens a new window for the resource.
 

Mouradif

Member
Amazing guide ! I have always wondered how do people find out all these steps :p. Anyway big up to you ! Tested and working on Ubuntu 19.10 with wine5.0
 

Cpaz

Member
The real question is: can this run on a rasberry pi 4 model B???

Guess we'll know this week cuz I'm gonna try my darnedest to get it working.
 
Has anyone had issues with GameMaker run through this method spitting out never-ending 'Changes made to project file' errors? I followed these instructions to install GameMaker under Wine about half of a year ago, and it was working just fine until March 9th, when, suddenly, whenever I have a project open in the IDE, it will spit out one of those errors every half of a minute or so, and neither saving nor reloading the assets fixes the problem. I have also tried deleting and re-creating the GameMaker prefix multiple times, reinstalling Wine multiple times, downgrading Wine, and even reinstalling Ubuntu [19.10] itself, all to no avail...
 

Samuel Venable

Time Killer
The real question is: can this run on a rasberry pi 4 model B???

Guess we'll know this week cuz I'm gonna try my darnedest to get it working.
It won't. I know of a way to get GM games on Pi. But it requires something I'm not allowed to talk about here.
 

Cpaz

Member
It won't. I know of a way to get GM games on Pi. But it requires something I'm not allowed to talk about here.
That's...
Cryptic. I've been looking into at least setting up a multi-platform pipeline... Somehow. Probably Jenkins if anything.

I've found that there is a version of Ubuntu that works on the pi 4, but it hangs like crap.
Then there's raspbian. I need to dig a bit deeper, but it seems possible...? By means of probably too many wrappers.

Still been investigating. But imma still tryin'.
 

Samuel Venable

Time Killer
Unless you do what I know about; you won't be able to. The Pi is arm architecture. The ubuntu module is amd64. It requires building your project with something that isn't GameMaker.

*runs away*
 

Tthecreator

Your Creator!
@Cpaz easiest would probably be to put android on the RPI and run it on that. I have no idea what the current state of android for RPI is right now though.

@Pir Jacques I'm very sorry to hear that. I'll try the latest version somewhere next week to see if I get the issue with an updated version.
 
Hello,
thanks a lot for this tutorial... stopped using GM:S about two years back because I had to use Windows.
But even though I actually am able to run GM:S it's unbearably slow.
Everything lags... even mouse clicks in editor / typing. Got i7 9700 with 64RAM so HW won't be a problem.
Running it on Ubuntu 19.10 / Wine 5.3
Has anyone met this issue? Any ideas of what to try to fix it?
 

Samuel Venable

Time Killer
Hey, I've decided to take down the download to krapOS, as I've run out of space on my Google Drive, and no one appears to have used it anyway. Just thought I'd let you know so you can update the topic.
 

Tthecreator

Your Creator!
Has anyone had issues with GameMaker run through this method spitting out never-ending 'Changes made to project file' errors? I followed these instructions to install GameMaker under Wine about half of a year ago, and it was working just fine until March 9th, when, suddenly, whenever I have a project open in the IDE, it will spit out one of those errors every half of a minute or so, and neither saving nor reloading the assets fixes the problem. I have also tried deleting and re-creating the GameMaker prefix multiple times, reinstalling Wine multiple times, downgrading Wine, and even reinstalling Ubuntu [19.10] itself, all to no avail...
So far I have not been able to recreate the issue. Does this also happen on empty/new projects? Do you have any programs running perhaps that check or run over files? Do you have your project saved within your wineprefix or somewhere else on your hdd?

@IceExplosive That is very strange. I get it sometimes and then other times it's gone. I will have to do more investigating.

@Samuel Venable It's sad to hear you are taking it down, but I haven't been using it myself either I must admit.

@❤️×1 How do I even @ your name? Anyways I'll add it to the post.
 
I've finally got it installed on Linux Mint 19.3 Tricia

I just installed the newest version of wine.
GML:
xfunk@xfunk-A315:~$ wine --version
wine-5.4
from there I carried on from here:

install wine:
sudo apt install --install-recommends winehq-devel
If everything went correctly "wine --version" should return "wine-4.10¨

and everything after
(note my wine says 5.4, but everything is working a-ok, I've tested building exe and HTML5 games. So far everything is good

Mouse wheel isn't working. If anyone knows how to fix that I'd be so happy :)
 

SgtLion

Member
Got this working fine on Fedora 31 by following instructions as written. Not sure if I was having an issue using Wine 5.7 (Staging) or it was a coincidence, but ended up doing a dnf downgrade wine to Wine 4.17 (Staging) and a winetricks --self-update before I got it working. Was having an issue for a while where GMS2 would not launch at all after installation, seemed to be some conflict with my Nvidia drivers, but it seems a reboot was all that was needed after installation! Been dying to get off Windows and GMS2 is all I use it for, so this is wonderful. Thank you!

EDIT: Holy moly, this works even better than I expected. Yay~. Make a frickin' native version YoYoGames geez.
 
Last edited:
Top