• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

SOLVED revert from 2.3.0 back down to 2.2.5?

JoltJab

Member
I had a rough problem happen when I moved from 2.2.5 to 2.3.0 .

See, the rooms I have in my game have an ungodly number of instances in them. In fact it is so bad, that in previous version of game maker the program would lag a little. I could deal with the lag, but when I updated from 2.2.5 to 2.3.0 I got a new problem. Opening my game maker file takes over 20 minutes now. And opening rooms to edit them takes 5+ minute each (depending on the size of the room). It use to just open right away, but now it takes forever to do anything. I would like to go back to 2.2.5 but are not sure how. I see a bunch of download pages when I google it, but none of them seem to be official from game maker which worries me a bit to download.

I have a version of the game saved to a 2.2.5 file, I just don't know how to get game maker 2.2.5.

thank you for taking the time to read
 

Corey Hardt

Member
Hey, would you mind posting the solution you found when saying that you solved the issue? Would help out others like me who are searching for answers to this same problem.
 

ensomari

Member
How did you downgrade? My builds have been failing at runtime since yesterday, without any error being displayed. I tried using the instructions here to use a different runtime, but I still couldn't select any other than the latest.
 

Non.A

Member
How did you downgrade? My builds have been failing at runtime since yesterday, without any error being displayed. I tried using the instructions here to use a different runtime, but I still couldn't select any other than the latest.
Same problem. It was working fine yesterday. Runtime Download didn't help me either. I'm new and not sure where to post the issue.
 

Attachments

Nocturne

Friendly Tyrant
Forum Staff
Admin
Go to the Release Notes from the HELP menu.
Open the "Older Versions" spoiler.
Click on the 2.2.5 link to download the installer.
Uninstall GMS 2.3.
Re-install 2.2.5.
Dance around the room with joy.

:bunny:

PS: Don't update 2.2.5 when propted, and pay attention to the RunTime version everytime you start the program as occasionally it'll try and use the 2.3 runtime when it should be using the 2.2.5.384 runtime..
 

ensomari

Member
Thanks, I tried uninstalling and reinstalling like you said, but now GMS 2.2.5 says "This project requires a newer version of the IDE and so will not be loaded. Please update your IDE to at least the version used to create the project, then try opening it again."
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
Open the 2.2.5 version of the YYP and not the 2.3.0 version. When you imported the 2.2.5 version into 2.3 you were prompted to save it in a different location, so don't use that one, use the original version of the project.
 
Top