• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows [RESOLVED] "Made with GameMaker Studio 2" splash screen won't go away while testing

Howdy. I have a big issue that involves the "Made with GameMaker Studio 2" splash screen. Every time I try to test my project, the screen won't go away. In fact, there is nothing there to be tested! I can't do anything at all except stare at the stupid screen. I ran it in debug mode and the system couldn't find a single error. A few months ago I had the 30-day demo version of the software. Whenever I tested my project there, It was fine. I have no idea what to do, so if somebody could help me, that would be great. Thanks.
 

rIKmAN

Member
Howdy. I have a big issue that involves the "Made with GameMaker Studio 2" splash screen. Every time I try to test my project, the screen won't go away. In fact, there is nothing there to be tested! I can't do anything at all except stare at the stupid screen. I ran it in debug mode and the system couldn't find a single error. A few months ago I had the 30-day demo version of the software. Whenever I tested my project there, It was fine. I have no idea what to do, so if somebody could help me, that would be great. Thanks.
What licence do you have?

If you have the Creators Licence then splash screens are enforced as part of it, and if you have a full Desktop Licence and are using the Mac IDE I believe the splash screens are also shown when testing due to some Apple requirements (there are previous threads about this if you search the forum).
 
the screen won't go away.
Do you mean you can't disable this screen, or that it literally remains on screen and your game doesn't start at all?

If your game isn't starting at all, its hard to say without more info. I can only theorize that there is an infinite loop at the very start of your game preventing it from proceeding. Or perhaps you need to clear the cache (click the broom icon in the toolbar) and try again.
 
Do you mean you can't disable this screen, or that it literally remains on screen and your game doesn't start at all?

If your game isn't starting at all, its hard to say without more info. I can only theorize that there is an infinite loop at the very start of your game preventing it from proceeding. Or perhaps you need to clear the cache (click the broom icon in the toolbar) and try again.
Yes, the logo remains on my screen. I'll give you a step-by-step procedure of what I've been doing.

1. Load up GameMaker
2. Go to my one and only test room
3. I run the game to test it
4. The splash screen stays.

I ran the game in the debugger and it said it was fine. Originally, the game was supposed to be launched in fullscreen. However, due to this technical difficulty I have changed it to the default windowed screen (because I thought this would fix the problem). The screenshot I inserted below is all I'm seeing. Hopefully you can help me out.
 

Attachments

What are the contents of your test room?

If you make a completely blank room with just the default black background, do you still get this problem?

Have you tested this with a new, blank project?
 
What are the contents of your test room?

If you make a completely blank room with just the default black background, do you still get this problem?

Have you tested this with a new, blank project?
Three "test walls," and my player object.

I never had a background to begin with, so I tried it with a background. That didn't work.
 
Have you tried it with a completely new, blank project and running it?

You could also try logging out of GMS 2 from the File menu and logging in again just in case its a license issue.
 
Top