Right now there are a couple of function naming conventions that are not working for me (wanted to read what you guys think on the matter). Code: string(number) takes a number and converts it to a string. Even though it seems logical to have the function be named "string" I do think the best option would be to have a "to_string(number)". This might not seem too obvious at first but makes sense when you look at the Code: string_format(val, tot, dec) function. This last one does exactly the same as the first but formats the result (decimal places and stuff). if you look to other naming conventions on GMS2 you see that Code: array_* functions are functions that are applied to arrays and Code: ds_list_* applies to lists (and so on), you get the point. So one would expect that string_format would apply to a string (and that is not true). Now imagine you want to actually make a function that formats strings like C# (String.Format()) there would be a name collision and you would need to name your function something less obvious. My alternative for naming conventions would be "to_string" (as a more general, convert number to string, convert arrays to string, maps to string, ....) or "num_to_string"