• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Discussion Quick workspace annoyance/solution (mouse wheel)

Cpaz

Member
EDIT: My initial issue was apparently being caused by external software, preventing mouse scrolling to work as it should. The following post assumed it was on GMS2 end. (The other edit still stands though)
For those wondering what fixed my issue. In x-mouse button control, disable the option:
"Make scroll wheel scroll window under cursor" in settings.

I use the zoom function. Definitely not in the actual workspace (at least not often).
I, more often than not, use scrolling with the mouse. Problem is, the mouse wheel functionality is global across EVERYTHING.
This isn't inherently bad, but I use the mouse wheel for different things depending on the tool. So swapping between the two through preferences isn't ideal. At all.
So instead of using control+mouse wheel, I propose having both scrolling and zooming be available at all times. One is available without holding control, the other is. This just kind of makes senses to me. This way, I can zoom in with the sprite and room editor, and scroll in the workspace.

EDIT: While I'm at it, perhaps a hotkey to quickly hide the side bars? (things like the resources and compile messages)
I'd imagine that would be something like the direction keys+control+alt or something.
 
Last edited:
I think I am missing something or misunderstanding. If I roll the mouse wheel (nothing else pressed), I scroll. If I press CTRL while rolling the mouse wheel, I zoom (in the room editor). So, this is already how GMS2 is working. What am I missing here? If you click in a code window and roll the mouse wheel, you scroll. So, again, what you are asking for is how the program works by default.
 

Cpaz

Member
I think I am missing something or misunderstanding. If I roll the mouse wheel (nothing else pressed), I scroll. If I press CTRL while rolling the mouse wheel, I zoom (in the room editor). So, this is already how GMS2 is working. What am I missing here? If you click in a code window and roll the mouse wheel, you scroll. So, again, what you are asking for is how the program works by default.
Well. That's not how it's working for me. Maybe they broke something in a recent update.
I have (to my knowledge) the most recent version of GMS2. So if you have the features I've mentioned, you either have an earlier version, I have a broken install, I missed something hidden the already messy preferences, or you're messing with me :p
(I'm joking about that last one of course)

EDIT: I can confirm I have version 2.0.5.74. The most recent version as of right now.
 

rIKmAN

Member
(Also, let us scroll in workspace windows (primarily the code editor). THAT is stupid to exclude.)
Are you sure the code window has enough code in it to need scrolling?
I was confused for a minute a few nights ago when I couldn't seem to scroll a code tab (it kept zooming the workspace), until I realised that there wasn't enough code to require any scrolling as the entire code was already visible - doh!
 

Cpaz

Member
Are you sure the code window has enough code in it to need scrolling?
I was confused for a minute a few nights ago when I couldn't seem to scroll a code tab (it kept zooming the workspace), until I realised that there wasn't enough code to require any scrolling as the entire code was already visible - doh!
Nope. I imported a project. So the scripts are large enough for it to be a concern.

That's the version I am running. It works for me like I said above with no issues.
Huh. Then maybe I have a bad install... Though, I have no idea how that would affect the IDE first.
 

Mike

nobody important
GMC Elder
CTRL+Mouse wheel = zoom
Mouse wheel = scroll
Shift+Mouse wheel = left/right scroll
F12 = hide/show docks.

These have been there for some time..... Make sure you don't have other software stealing key presses. Intel graphics card drivers are bad for this.
 

Cpaz

Member
CTRL+Mouse wheel = zoom
Mouse wheel = scroll
Shift+Mouse wheel = left/right scroll
F12 = hide/show docks.

These have been there for some time..... Make sure you don't have other software stealing key presses. Intel graphics card drivers are bad for this.
I don't believe so. I have an AMD cpu and an NVIDIA gpu, so I don't believe there should be anything of the sort. I guess I'll try reinstalling then.

EDIT: apparently, X-mouse button control was stealing inputs. I'll have to tweak that.
Regardless, thanks for helping me out with this everyone! (OP will be edited)
 
Last edited:
J

jbeninger

Guest
I had the same problem with StrokesPlus, and had to disable it for GameMaker. Looks like GM uses a different method to capture scroll events than most applications.
 
I use X-Mouse Button Control to finely tune what my fourth and fifth mouse buttons do. And, in the "Options" tab, there is a checkbox to "Disable Scroll Window Under Cursor." I had it unchecked. And, apparently, having it unchecked meant that I couldn't freely scroll up and down through the code inside of windows in GMS2 with the mousewheel. I unchecked this setting, and I can now freely scroll up and down inside windows in GMS2.

Thanks to you.

Thank you.
 
Top