• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

GMS 2.3+ Project "loading" infinitely, never opens (converted from 2.2.5)

jedy567

Member
I have a project that I converted to 2.3 a few hours ago, and I did some re-organizing within the asset browser and applied a few tags to objects. After saving, closing, then re-opening the project, it reaches about 90% on the "loading" bar in the top right corner of the IDE, but the loading icon next to that continues to spin indefinitely, while the workspace and asset browser remain blank. If I close the IDE, it closes immediately without any confirmation boxes (I have those set to enabled). I have restarted my computer. Other projects load correctly as well.

Are there perhaps any temporary cached files in Windows that I could delete and force GMS2 to re-populate?

This is on IDE v2.3.0.529 and runtime 2.3.0.401.
 

jedy567

Member
The output window is entirely empty, but the first line in "highlighted" in gray, and if you click, a blink text cursor appears (almost like you can type into the gray portion). Strangely enough, even though windows cursor is a blue "loading" circle, I can click on the docked tabs at the bottom (search results, output window, compile errors, etc) and those other windows appear normal.
 
The output window is entirely empty, but the first line in "highlighted" in gray, and if you click, a blink text cursor appears (almost like you can type into the gray portion). Strangely enough, even though windows cursor is a blue "loading" circle, I can click on the docked tabs at the bottom (search results, output window, compile errors, etc) and those other windows appear normal.
You should send that as (yet another) bug report to tech support. I've been toying around with 2.3 myself and have been typing mail after mail.
 
Top