• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

HTML5 Project Failed to load

mproxima

Member
I was working with this project fine till yesterday, It was not long I started working on it so I haven't made a backup yet.
It dosn't even load in anymore.

load.png

This is the only message I get. I tried to load an older version and import the new rooms and objects I made but it dosen't allow me to do it giving me the same error message.
Does anyone have a clue about this?
Thanks!
 

Dan

YoYo Games Staff
YYG Staff
Please check outside GMS2 (.g., using Notepad) if that .yyp file mentioned on that error popup has any content inside it or if it has somehow become blanked.

If the .yyp file still has stuff in it, then please zip up the whole project folder and send us a bug report with a link for us to download that .zip, then we will see if we can load the project here.

Unfortunately, if the .yyp has become empty for whatever reason, then we are unable to repair the project. However, hopefully all your sprites/objects/etc. are still there on disk, so you can create a new project and copy/paste all your code back in/relink all the images and sounds, etc.


Did you perhaps have your computer crash yesterday whilst GMS2 was open, anything like that? This could cause the file to be wiped on your disk.

I would also suggest you check out our permissions FAQ in case some protection software locked the file and broke the save process/reverted it for you - https://help.yoyogames.com/hc/en-us...missions-and-Internet-Access-Required-by-GMS2
 

mproxima

Member
Looks like there's stuff in it, I read about some people that have it reduced to 0 kb but seems not the case this time.
I've zipped where I can send the files?

Thank you so much for the quick response
 

mproxima

Member
Thank you everything solved using the YYP Maker! wew
Now that I see the project was html 5 and I probably switched and saved in Windows maybe causing some issues.

Thank you again!
 

TsukaYuriko

☄️
Forum Staff
Moderator
For the record, switching export targets is a core feature of GameMaker Studio and should not under any circumstances break your project.
 

mproxima

Member
Yeah it worked really well all this time I switched on and off all the time. Just trying to get a clue at what could have been causing the issue
 
Top