Programming issues

Q

QuoteTheRobot

Guest
Hello, everyone! I'm currently following this video series:
I'm on Episode 4, at the 19:39 time, and I'm having an issue. I have copied all the code from it up to this point, and did some working around, but the game won't load up. Here's what I got from the output:
"cmd" /c subst Z: "C:\Users\Hi\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE"

elapsed time 00:00:00.0620035s for command "cmd" /c subst Z: "C:\Users\Hi\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE" started at 11/29/2018 21:15:39
"cmd" /c subst Y: "C:\Users\Hi\AppData\Local\GameMakerStudio2\GMS2TEMP"

elapsed time 00:00:00.0590034s for command "cmd" /c subst Y: "C:\Users\Hi\AppData\Local\GameMakerStudio2\GMS2TEMP" started at 11/29/2018 21:15:39
"cmd" /c subst X: "C:\ProgramData\GameMakerStudio2\Cache\runtimes\runtime-2.2.0.258"

elapsed time 00:00:00.0600035s for command "cmd" /c subst X: "C:\ProgramData\GameMakerStudio2\Cache\runtimes\runtime-2.2.0.258" started at 11/29/2018 21:15:39
Saving project to: C:\Users\Hi\Documents\GameMakerStudio2\Test Land\Test Land.yyp
"C:\ProgramData/GameMakerStudio2/Cache/runtimes\runtime-2.2.0.258/bin/Igor.exe" -options="C:\Users\Hi\AppData\Local\GameMakerStudio2\GMS2TEMP\build.bff" -- Windows Run

Loaded Macros from C:\Users\Hi\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE\Test_Land_15D7AA6\macros.json
Options: X:/bin\platform_setting_defaults.json
Options: C:\Users\Hi\AppData\Roaming/GameMakerStudio2\protofan9_1802770\local_settings.json
Options: C:\Users\Hi\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE\Test_Land_15D7AA6\targetoptions.json
X://bin/GMAssetCompiler.exe /c /zpex /mv=1 /iv=0 /rv=0 /bv=0 /j=4 /gn="Test Land" /td="Y:/" /cd="Z:/Test_Land_15D7AA6" /zpuf="C:\Users\Hi\AppData\Roaming/GameMakerStudio2\protofan9_1802770" /m=windows /tgt=64 /nodnd /cfg="default" /o="Y:/Test_Land_2031AB76_VM" /sh=True /optionsini="Y:/Test_Land_2031AB76_VM\options.ini" /cvm /baseproject="X:/BaseProject\BaseProject.yyp" "C:\Users\Hi\Documents\GameMakerStudio2\Test Land\Test Land.yyp" /preprocess="Z:/Test_Land_15D7AA6"
Reading project file....C:\Users\Hi\Documents\GameMakerStudio2\Test Land
Reading project file....X:\BaseProject
Reading config delta 'C:\Users\Hi\Documents\GameMakerStudio2\Test Land\options\main\inherited\options_main.inherited.yy'
finished.


X://bin/GMAssetCompiler.exe DONE (0)
Release build
OptionsIni
Options: Z:/Test_Land_15D7AA6\PlatformOptions.json
[Compile] Run asset compiler
C:\Windows\system32\cmd.exe /c ""X://bin/GMAssetCompiler.exe" /c /zpex /mv=1 /iv=0 /rv=0 /bv=0 /j=4 /gn="Test Land" /td="Y:/" /cd="Z:/Test_Land_15D7AA6" /zpuf="C:\Users\Hi\AppData\Roaming/GameMakerStudio2\protofan9_1802770" /m=windows /tgt=64 /nodnd /cfg="default" /o="Y:/Test_Land_2031AB76_VM" /sh=True /optionsini="Y:/Test_Land_2031AB76_VM\options.ini" /cvm /baseproject="X:/BaseProject\BaseProject.yyp" "C:\Users\Hi\Documents\GameMakerStudio2\Test Land\Test Land.yyp" /bt=run"
Reading project file....C:\Users\Hi\Documents\GameMakerStudio2\Test Land
Reading project file....X:\BaseProject
Reading config delta 'C:\Users\Hi\Documents\GameMakerStudio2\Test Land\options\main\inherited\options_main.inherited.yy'
finished.
Compile Constants...finished.
Remove DnD...finished.
Compile Scripts...finished.
Compile Objects...finished.
Compile Timelines...finished.
Compile Triggers...finished.
Compile Rooms...finished.
Compile Extensions...finished.
Global scripts...finished.
Error : gml_Object_oEnemy_Draw_0(2) : malformed if statement
Final Compile...finished.
Saving IFF file... Y:/Test_Land_2031AB76_VM\Test Land.win
Writing Chunk... GEN8
option_game_speed=60
Writing Chunk... OPTN
Writing Chunk... LANG
Writing Chunk... EXTN
Writing Chunk... SOND
Writing Chunk... AGRP
Writing Chunk... SPRT
Writing Chunk... BGND
Writing Chunk... PATH
Writing Chunk... SCPT
Writing Chunk... GLOB
Writing Chunk... SHDR
Writing Chunk... FONT
Writing Chunk... TMLN
Writing Chunk... OBJT
Writing Chunk... ROOM
Writing Chunk... DAFL
Writing Chunk... EMBI
Writing Chunk... TPAGE
Texture Group - Default
Writing Chunk... CODE
Writing Chunk... VARI
Writing Chunk... FUNC
Writing Chunk... STRG
Writing Chunk... TXTR
0 Compressing texture... writing texture texture_0.png...
Writing Chunk... AUDO
Writing Chunk... SCPT
Writing Chunk... DBGI
Writing Chunk... INST
Writing Chunk... LOCL
Writing Chunk... STRG
Stats : GMA : Elapsed=711.0407
Stats : GMA : sp=10,au=0,bk=0,pt=0,sc=0,sh=1,fo=0,tl=0,ob=5,ro=1,da=0,ex=0,ma=42,fm=0x4000200448A80020


C:\Windows\system32\cmd.exe exited with non-zero status (1)
elapsed time 00:00:02.6701527s for command "C:\ProgramData/GameMakerStudio2/Cache/runtimes\runtime-2.2.0.258/bin/Igor.exe" -options="C:\Users\Hi\AppData\Local\GameMakerStudio2\GMS2TEMP\build.bff" -- Windows Run started at 11/29/2018 21:15:39
"cmd" /c subst Z: /d

elapsed time 00:00:00.0630036s for command "cmd" /c subst Z: /d started at 11/29/2018 21:15:42

Yeah, there's a lot of stuff in there. If anyone knew what was going on and had a solution to it, that would be awesome, thanks! (P.S. If you need any parts of the code for checking reasons, just ask, and I'll post it. Thanks!)
 

FrostyCat

Member
Want to know the point of error messages? It's for you to READ.
Code:
Error : gml_Object_oEnemy_Draw_0(2) : malformed if statement
This particular error usually stems from missing brackets or braces, or an inappropriate semicolon between the condition and the opening brace.

Topics like this are the reason why I recommend becoming familiar with basic GML syntax before starting on video tutorials. Anyone who knows what a proper if statement looks like and isn't a blind copy-and-paster could have scrapped it out themselves.
 
Q

QuoteTheRobot

Guest
Not sure if the snark was really required, but pointing that part of the error message helped me fix it up. Thanks for the help!
 
C

Caedmon

Guest
Can i ask you a question while youre at it? I am also following this series but i have some major collision issues if i am touching a wall thats on the left i cant get out without jumping and am therefore stuck on the first two videos.
Do you know what might help?
 

TheouAegis

Member
Check your sprites. Sounds like your sprites aren't centered or sized properly, so changing sprites migjt be putti g the bound8ng box inside the wall
 
C

Caedmon

Guest
Check your sprites. Sounds like your sprites aren't centered or sized properly, so changing sprites migjt be putti g the bound8ng box inside the wall
Thank you for your feedback i will check the sprites, their origins and their collision masks!
 
C

Caedmon

Guest
Check your sprites. Sounds like your sprites aren't centered or sized properly, so changing sprites migjt be putti g the bound8ng box inside the wall
This didnt work despite my collision masks being exactly the same on everything i need some help
 

TheouAegis

Member
What's the part of your code that deals with HORIZONTAL collisions? If you're sure it's not the sprites, then we need to make sure you don't have a typo that is forcing horizontal collisions to occur on accident.
 
Q

QuoteTheRobot

Guest
Yeah, rewatching the videos and checking to see if you didn't make any typos is golden. Actually, while I'm on it, when the oDead sprites fall, they stay in their first animation, and just slide to the right. What's up with that?
 

TheouAegis

Member
Sounds like you have one of the built-in speed variables set to something on accident. Or you set horizontal speed instead of vertical speed on accident.
 
Top