• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

GMS 2.3+ Problems converting projects from 2.2 to 2.3

Dukebot

Member
I have updated my Game Maker Studio 2 version and I have problem converting some of the projects that I have from the old version. I get the following error message and I don't have any clue what's wrong or how to fix.

r/gamemaker - GMS2: Problem when importing project from 2.2.5 to 2.3 version

The full message says "Resource file is malformed 'rooms/rMenu/rMenu.yy' An item with the same key has already been added."

Anyone else has had this issue and know how to fix it?
 

Shockman

Member
HAVE the issue yes. Know how to fix it no.
My report gives no detail though just says it failed.
Were you able to revert back to 2.25?
 

dino1489

Member
Link:

Quote:
Report any bugs!
Obviously, please do have a lot of fun trying out all the new changes and playing around with the new capabilities 2.3.0 offers. The manual should have content for all of the above changes, so if you spot something is missing or feel the level of information given is lacking, do let us know.

Should you have a project which fails to import from 2.2.5 to 2.3.0, please do report this and give us a download link for the original .yyz you're trying to import. We would note that if the project wasn’t exported from 2.2.5.481, then you check your .yyz does import correctly in 2.2.5.481 and then you re-export it, as that 2.2.5 release had a number of fixes and “preparation changes” for the move to 2.3.0 – if it still fails after re-exporting from 2.2.5.481, then please send that new .yyz to us.
I'm chasing the same issue right now and I read this from a month ago.

The notes also have the previous version ( 2.2.5.481 ).


Update:
So Personally Mine Breaks from
IDE v2.2.4.474 [Runtime v2.2.5.378] to IDE v2.2.4.474 [Runtime v2.2.5.401]



Scripts now contain functions
  • A script asset is no longer limited to being just one custom function - instead, you will find a new function declaration is added whenever you create a script, and you can add your own below this and call these functions as required elsewhere in your game
  • Scripts are also now processed on startup, which means if you create a script which contains lines which are not wrapped in a function declaration, those lines will always run on game start, allowing you to very easily create initialisation scripts and control functionality
  • NOTE: You should review your scripts after importing any 2.2.5 projects in case you need to remove/tweak these function declarations so that your game initialises correctly.
This is probably why for me. I'm ganna have to go through a lot of stuff.
 
Last edited:

Dukebot

Member
HAVE the issue yes. Know how to fix it no.
My report gives no detail though just says it failed.
Were you able to revert back to 2.25?
I have not tryed to revert back, because I want to be able to convert the project for future maintenance. I am getting this error with 3 projects or so and it's important for me to be able to convert them.


EDIT: If it helps here is the download link to my project.
 
Last edited:

dino1489

Member
I sent in a ticket and my project, and they fixed it. The thing I noticed is that all my scripts were updated so I was on the right track. It took a while to respond, but they did helped.
GML:
function ani_call(argument0, argument1) {

    var _animation, _sprite

    _animation=argument0;
    _sprite=argument1;

    frame=0;
    animation=_animation;
    sprite_index=_sprite;



}
There are probably other things that changed, but I can't find them. Another thing I noticed is that rooms didn't show up on the room order manager, but if you duplicate the rooms the duplicates show up - simple enough, didn't wanna waste their time for that. I can't really open my project before and after cause I only have one computer, but I know scripts are different at least. Anyways that's all I really got. Here is the link, hope it helps.

 
Top