• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Problem with manifest.xml and cannot set up Windows 8 settings

S

Shin Kitsune

Guest
Good day!
I have got Game Maker Studio 1.4 for a while now, got it thanks to the Humble "Play and Create with GameMaker" Bundle.
I had been slowly learning to use it, and have had no problems with it until now. Thing is, I just got Game Maker Studio 2 Desktop as well, so I don't know if GMS2 might be causing this issue.
The thing is when I try to run Game Maker Studio 1.4, I get two error messages before the main window shows up.
upload_2017-5-16_6-42-44.png
upload_2017-5-16_6-43-16.png
I go to the %LocalAppData%\gamemaker_studio\lib\assets folder where the culprit file is, and when I open it, it only contains this line:

There are no purchases
I tried deletting the file, I tried removing that line from the XML and even <--! commenting it out -->, but it comes back every time I run the software...

Like I mentioned, I got Game Maker Studio 1.4 through Humble Bundle, and got the Steam key later. And I also bought Game Maker Studio 2 through Steam yesterday, so I can assure you it's not pirated software. Also worth mentioning, this does not happen on GMS2, or in my other operating system where I don't have GMS2 installed. This is why I suspect GMS2 might be causing some conflict.

What can I do to fix this issue?

Thanks in advance!
 
Last edited by a moderator:
S

Shin Kitsune

Guest
Bump, and also an update I would like to mention as well...
I have recently upgraded my Visual Studio installation from VS 2013 to VS 2015. I had to reconfigure some settings. Most of them worked fine, but I'm getting an error when I try setting the WinJS API reference, I get this error:
upload_2017-5-18_6-2-11.png

And in the compile messages I get this error:
ERROR: Cannot determine the location of the VS Common Tools folder.
The environment variable ExtensionSdkDir is not set.


I've checked the data, and it should be correct. I've followed the instructions to correctly configure this part. When I try creating a blank JavaScript application and looking for the SDK Identity property, this is what I get in Properties:
Microsoft.WinJS.2.0, Version=1.0
 
Last edited by a moderator:
Top