• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Steam Problem with acquiring license in GMS 1.4

_Steiner

Member
Hi everyone. Today I tried installing GMS 1.4 and when I log in to my account, I get this message:

Element "array" does not contain a single text node.

What can I do to solve that?
 

rIKmAN

Member
Are you using 1.4.9999?
The errors on startup were fixed in the final version, previous versions try to connect to now defunct servers.
 

rIKmAN

Member
I'm using the one available in the download section.
I'm not sure what that version is tbh as it was so long ago I last downloaded or used 1.4, but I just fired up v1.4.9999 here and don't get any errors at startup.
You can see the first entry in the GMS 1.4 Release Notes mentions removal of the online connectivity, specifically the News Feed which is what the startup errors were in previous versions.

Does the message prevent you from logging in and using it?
 

_Steiner

Member
I'm not sure what that version is tbh as it was so long ago I last downloaded or used 1.4, but I just fired up v1.4.9999 here and don't get any errors at startup.
You can see the first entry in the GMS 1.4 Release Notes mentions removal of the online connectivity, specifically the News Feed which is what the startup errors were in previous versions.

Does the message prevent you from logging in and using it?
Yeah, I can't log in because the acquiring license screen gets stuck. I believe the version I'm using is 1.4.9999 because the download section in the dashboard shows the release notes of it.
 

rIKmAN

Member
Yeah, I can't log in because the acquiring license screen gets stuck. I believe the version I'm using is 1.4.9999 because the download section in the dashboard shows the release notes of it.
Yeah I'd assume it's 1.4.9999 on the website but wasn't sure you meant the YYG website - as I say I can open it here without any issues or errors.
I see you've used the "Steam" tag on this thread - have you tried using the standalone version?

Someone made a long post detailing a lot of the issues that can happen when trying to still use 1.4, take a look through the info they posted and see if anything listed might help.
 
Last edited:

_Steiner

Member
Yeah I'd assume it's 1.4.9999 on the website but wasn't sure you meant the YYG website - as I say I can open it here without any issues or errors.
I see you've used the "Steam" tag on this thread - have you tried using the standalone version?

Someone made a long post detailing a lot of the issues that can happen when trying to still use 1.4, take a look through the info they posted and see if anything listed might help.
Hi. Sorry to reply you more than 2 months later, but I forgot to do so that day. The reason I used the "Steam" tag was that I bought GMS2 there, and it came with a GMS1.4 license. I still don't know what to do, or maybe I should downgrade to an older version of 1.4.
 

rIKmAN

Member
Hi. Sorry to reply you more than 2 months later, but I forgot to do so that day. The reason I used the "Steam" tag was that I bought GMS2 there, and it came with a GMS1.4 license. I still don't know what to do, or maybe I should downgrade to an older version of 1.4.
If you have GMS2, why are you wanting to use 1.4?
If you have to use 1.4 for some reason, then use v1.4.9999.

However I'd 100% recommend using GMS2 and forgetting about 1.4.
 

_Steiner

Member
If you have GMS2, why are you wanting to use 1.4?
If you have to use 1.4 for some reason, then use v1.4.9999.

However I'd 100% recommend using GMS2 and forgetting about 1.4.
I want to use 1.4 because I wanted to try an engine created with 1.4 as a base called Megamix. Is it legal to have both an original license and a pirated license?
 

rIKmAN

Member
I want to use 1.4 because I wanted to try an engine created with 1.4 as a base called Megamix.
Then use 1.4.9999 - you can download it from the GMS1.4 Release Notes or by from the download area on the YYG site after logging in with your account.
Is it legal to have both an original license and a pirated license?
You said you own GMS2 and a 1.4 licence came free with it - although free 1.4 licences with GMS2 purchases stopped happening a long time ago so as you've mentioned piracy I assume it was a lie and your version of 1.4 is pirated which of course isn't legal. You won't get any help with that here and may be banned, so tread carefully.

Import the 1.4 project into GMS2 and work with it there.
 
Last edited:

_Steiner

Member
Then use 1.4.9999 - you can download it from the GMS1.4 Release Notes or by from the download area on the YYG site after logging in with your account.

You said you own GMS2 and a 1.4 licence came free with it - although free 1.4 licences with GMS2 purchases stopped happening a long time ago so as you've mentioned piracy I assume it was a lie and your version of 1.4 is pirated which of course isn't legal. You won't get any help with that here and may be banned, so tread carefully.

Import the 1.4 project into GMS2 and work with it there.
I don't have a pirated license of 1.4, It was only a question. I bought GMS2 from Steam and when I linked my account, it gave me a free download of 1.4 in my dashboard.
 

rIKmAN

Member
I don't have a pirated license of 1.4, It was only a question. I bought GMS2 from Steam and when I linked my account, it gave me a free download of 1.4 in my dashboard.
Seems odd that you'd own licences to both and ask a question about whether having a pirated version is legal.

The error you are getting usually happens with version < 1.4.9999 which still do server checks - so get the latest version.
I just opened my own version of 1.4.9999 and it works fine as it does no online checks - the Release Notes I linked have more info on this in the first section.

Anyway, my advice stands:
If you have to use 1.4 then use 1.4.9999.
If you don't then use GMS2.

Remember that you can import 1.4 projects into GMS2 so you could also do that with the Megamix project you want to use.
 

_Steiner

Member
Seems odd that you'd own licences to both and ask a question about whether having a pirated version is legal.

The error you are getting usually happens with version < 1.4.9999 which still do server checks - so get the latest version.
I just opened my own version of 1.4.9999 and it works fine as it does no online checks - the Release Notes I linked have more info on this in the first section.

Anyway, my advice stands:
If you have to use 1.4 then use 1.4.9999.
If you don't then use GMS2.

Remember that you can import 1.4 projects into GMS2 so you could also do that with the Megamix project you want to use.
I don't know if I really have the license or it's only the free download at the YYG Dashboard. Also, I forgot to mention I was talking about 1.4.9.
 

rIKmAN

Member
I don't know if I really have the license or it's only the free download at the YYG Dashboard. Also, I forgot to mention I was talking about 1.4.9.
So login to your YYG account and check what licences you have - it will tell you there what licences you own for each version.
Once logged in go to GAMEMAKER > Products in the left hand menu and then click the GMS2 or GMS1.4 headers to show your licences and their status.

The error messages on startup were fixed in v1.4.9999 (as mentioned in the Release Notes) although there can be other issues installing it which is why I linked you to the other troubleshooting post back up near the top of this thread.
 
Top