• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows Problem when I run a project after the update to 2.3.0

Hi guys, after the update to the 2.3.0 version when I run a project (converted to 2.2.5 or not) I can only see the background and hear the music, nothing else. Object and tilesets seem invisible.
I have already reported this problem as a bug to YoYo. They suggest to switch the graphic card to a more powerful one if there was the opportunity. So I switch from Intel(R) UHD Graphics 630 to my NVIDIA GeForce GTX 1050 but the problem persist.
I have created a new project completely in the new 2.3.0 version where there is only a green square on a black background (AloneInTheSquare). I attach the screenshots of the project and the debug output.
Hope someone could help me.

Here the Debug Output:

"cmd" /c subst Z: "C:\Users\aleml\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE"

elapsed time 00:00:00.0407153s for command "cmd" /c subst Z: "C:\Users\aleml\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE" started at 08/25/2020 18:35:16
"cmd" /c subst Y: "C:\Users\aleml\AppData\Local\GameMakerStudio2\GMS2TEMP"

elapsed time 00:00:00.0399393s for command "cmd" /c subst Y: "C:\Users\aleml\AppData\Local\GameMakerStudio2\GMS2TEMP" started at 08/25/2020 18:35:16
"cmd" /c subst X: "C:\ProgramData\GameMakerStudio2\Cache\runtimes\runtime-2.3.0.401"

elapsed time 00:00:00.0398418s for command "cmd" /c subst X: "C:\ProgramData\GameMakerStudio2\Cache\runtimes\runtime-2.3.0.401" started at 08/25/2020 18:35:16
"C:\ProgramData/GameMakerStudio2/Cache/runtimes\runtime-2.3.0.401/bin/Igor.exe" -j=8 -options="C:\Users\aleml\AppData\Local\GameMakerStudio2\GMS2TEMP\build.bff" -v -- Windows Run

Loaded Macros from C:\Users\aleml\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE\AloneInThe_AE2BEE8E_40946038\macros.json
Options: X:/bin\platform_setting_defaults.json
Options: C:\Users\aleml\AppData\Roaming/GameMakerStudio2\alemleonardo_2342422\local_settings.json
Options: C:\Users\aleml\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE\AloneInThe_AE2BEE8E_40946038\targetoptions.json
Setting up the Asset compiler
X://bin/GMAssetCompiler.exe /c /mv=1 /zpex /iv=0 /rv=0 /bv=0 /j=8 /gn="AloneInTheSquare" /td="Y:/" /cd="Z:/AloneInThe_AE2BEE8E_40946038" /zpuf="C:\Users\aleml\AppData\Roaming/GameMakerStudio2\alemleonardo_2342422" /m=windows /tgt=64 /nodnd /cfg="Default" /o="Y:/AloneInTheSquare_4E268C79_VM" /sh=True /optionsini="Y:/AloneInTheSquare_4E268C79_VM\options.ini" /cvm /baseproject="X:/BaseProject\BaseProject.yyp" "C:\Users\aleml\OneDrive\Documenti\GameMakerStudio2\AloneInTheSquare\AloneInTheSquare.yyp" /preprocess="Z:/AloneInThe_AE2BEE8E_40946038"
Found Project Format 2
ProjectFileWatcher:StartWatching:C:\Users\aleml\OneDrive\Documenti\GameMakerStudio2\AloneInTheSquare
Started: 25/08/2020 18:35:17
Finished: 25/08/2020 18:35:18
Diff: 00:00:00.3605808
Loaded Project: AloneInTheSquare
finished.
Debug build
Options: Z:/AloneInThe_AE2BEE8E_40946038\ExtensionOptions.json
OptionsIni
Options: Z:/AloneInThe_AE2BEE8E_40946038\PlatformOptions.json
[Compile] Run asset compiler
X://bin/GMAssetCompiler.exe /c /mv=1 /zpex /iv=0 /rv=0 /bv=0 /j=8 /gn="AloneInTheSquare" /td="Y:/" /cd="Z:/AloneInThe_AE2BEE8E_40946038" /zpuf="C:\Users\aleml\AppData\Roaming/GameMakerStudio2\alemleonardo_2342422" /m=windows /tgt=64 /nodnd /cfg="Default" /o="Y:/AloneInTheSquare_4E268C79_VM" /sh=True /optionsini="Y:/AloneInTheSquare_4E268C79_VM\options.ini" /cvm /baseproject="X:/BaseProject\BaseProject.yyp" "C:\Users\aleml\OneDrive\Documenti\GameMakerStudio2\AloneInTheSquare\AloneInTheSquare.yyp" /dbgp=6509 /debug /nofs /bt=run /rt=vm
Compile Constants...finished.
Remove DnD...finished.
Compile Scripts...finished.
Compile Rooms...finished.
Compile Objects...finished.
Compile Timelines...finished.
Compile Triggers...finished.
Compile Extensions...finished.
Global scripts...finished.
finished.
collapsing enums.
Final Compile...finished.
Saving IFF file... Y:/AloneInTheSquare_4E268C79_VM\AloneInTheSquare.win
Writing Chunk... GEN8
option_game_speed=60
Writing Chunk... OPTN
Writing Chunk... LANG
Writing Chunk... EXTN
Writing Chunk... SOND
Writing Chunk... AGRP
Writing Chunk... SPRT
Writing Chunk... BGND
Writing Chunk... PATH
Writing Chunk... SCPT
Writing Chunk... GLOB
Writing Chunk... SHDR
Writing Chunk... FONT
Writing Chunk... TMLN
Writing Chunk... OBJT
Writing Chunk... ACRV
Writing Chunk... SEQN
Writing Chunk... TAGS
Writing Chunk... ROOM
Writing Chunk... DAFL
Writing Chunk... EMBI
Writing Chunk... TPAGE
Texture Group - Default
Writing Chunk... TGIN
Writing Chunk... CODE
Writing Chunk... VARI
Writing Chunk... FUNC
Writing Chunk... STRG
Writing Chunk... TXTR
0 Compressing texture... writing texture texture_0.png...
Writing Chunk... AUDO
Writing Chunk... SCPT
Writing Chunk... DBGI
Writing Chunk... INST
Writing Chunk... LOCL
Writing Chunk... DFNC
Writing Chunk... STRG
Stats : GMA : Elapsed=476,3893
Stats : GMA : sp=1,au=0,bk=0,pt=0,sc=0,sh=0,fo=0,tl=0,ob=1,ro=1,da=0,ex=0,ma=3,fm=0x200000000000
DoSteam
Igor complete.
[Run] Run game
Options: Z:/AloneInThe_AE2BEE8E_40946038\MainOptions.json
[Debugger]target=127.0.0.1,yydebug="Y:/AloneInTheSquare_4E268C79_VM\AloneInTheSquare.yydebug"
X://windows/Runner.exe -game "Y:/AloneInTheSquare_4E268C79_VM\AloneInTheSquare.win"
Attempting to set gamepadcount to 12
DirectX11: Using hardware device
Start debug server
Creating Debugger server port:6509
[DbgServer]6509
Collision Event time(microsecs)=2
Waiting for debugger to connect...
Client(-1) Connected: 127.0.0.1
Debugger connected
1 code buffers added (74)

Total memory used = 7775894(0x0076a696) bytes
**********************************.
Entering main loop.
**********************************.
Pause event has been registered for this frame
Pause event has been unregistered



screenshot of the object
screenshot GMS 2.png


screenshot of the sprite
screenshot GMS 1.png


screenshot of the room
screenshot GMS 3.png


screenshot of the run game with only the black backround
screenshot GMS 4.png
 

Honikal

Member
I know I'm really late... but since the problem happens to me I think is because of the igor file, strangely, my antivirus has been deleting the same file, which is important to run the runtime and I think loading the archives, I think it happened because the antivirus (specially Avast) think Igor is a virus, and put him in the "punishment corner", so everytime you uninstall and reinstall the program, it will keep deleating the file, I tell you, the same problem happened to me, and it's happening, I don't know how I'm going to make it stop deleating the igor archive, but I tell you... that's a big problem of Game Maker Studio 2 and Avast Antivirus. I hope this helped (and... I think they kinda made you buy the graphic card for an innecesary reason, but hey! You can now handle more things), have a good day/night.
 
Top