• Hey! Guest! The 39th GMC Jam will take place between November 26th, 12:00 UTC and November 30th, 12:00 UTC. Why not join in! Click here to find out more!
  • Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows Please help! ALL my graphics, tiles etc have disapeared in the Editor and Game?! Perhaps corrupted project? GUI/Compiler bug?

Hi. I'm relatively new to Game Maker Studio, I bought it a month ago and have been working on a project every day since. I've been getting on really well so far and enjoyed it, had no problems.

Suddenly, I load the project today, and its as if the file has somehow corrupted - in the room editor, NO Tiles are visible, regardless of whether they are set to visible or not. The sprite image for the tilesets is visible in the right hand panel, but no tiles appear in the Room editor. In the room editor, only sprites are visible.

When I run the game with F5, even worse, not only are no tiles visible, but also no sprites! The only thing that appears on screen is my debugging text. The game appears to play perfectly with no graphics, as I can see the debug variables changing.

Again, in the resources panel, all sprite images are absolutely fine. But for some reason the tiles are missing from the room editor, and both the tiles and sprites are missing from the game when running.

I wondered if I'd accidentally nudged something in the layouts or something but I've reset everything to default and it didn't change anything.

Obviously I've also tried rebooting my PC, loading it fresh etc. No dice.

I have a backup version of the project from a week ago (I backup my work documents once a week), and when I load that version, the tiles and sprites appear as normal! So it would appear its not GameMaker itself, just this particular project.

I actually took a week off work for various reasons and have been working for many hours a day on this project over the last week and I REALLY don't want to have to lose all that progress and go back to the old backup. Also, I want to know what happened so I can try and avoid this issue in the future.

This all happened when I just loaded the project up fresh when I wanted to start working on it today. The first thing I did was press F5 and run the game and all I got was the background colour, plus debug text. I wondered if somehow this background layer was taking priority and displaying over the top, so I deleted it. All this did was give me the debug text over a black screen instead. I mention this, incase there is some stipulation that I didn't realise where you are required a background layer for a game to run properly or something.

If anyone can help I will be eternally grateful as the thought of losing my whole week off's worth of progress is driving me nuts.

[EDIT] OK here's something VERY weird I've just noticed... pausing the game brings up my pause menu and it works perfectly (The pause menu is very elaborate with multiple pages for options etc, and it has a 9-slice style sprite based border, which is displaying perfectly, despite none of the other sprites displaying. These sprites are being drawn to the GUI layer which is on top of everything else, and is also where that debug text is drawn, so it seems like taht whole layer is displaying, whereas literally nothing else is.
 
Last edited:

Roldy

Member
In the room editor Center everything to make sure it is in view:
1595548436350.png

In the layer makes sure your tile/instance layers are not hidden:
1595548486549.png
In the room properties if you are using camera and view make sure they are enabled and the settings make sense:

1595548577870.png
 
Thank you for the above advice, I'd already tried all of that.

I think I've worked out what happened somehow. In the "Room Settings", the Room size should be 42400 x 24000, however, somehow it had become 424 x 240. I have literally no idea how that happened. Setting it back to the full size again meant that suddenly I can play the game and all my sprites will appear and behave as expected. However, all the tiles I previously placed are all missing - it seems that when the room size somehow was made smaller, all tiles out of the size area disapeared. Now replacing brand new ones, they work fine.

This is somewhat of a relief that I can "fix" the issue and I havent lost all my programming etc. However, as you can imagine, with a Room size of 42400 x 24000 there were literally tens of thousands of 16x16 tiles over multiple layers (foreground, background, secret areas etc). Is there any way whatsoever that I can hope to retrieve these? Is it possible to import the tile layers from my week old backup?
 
Thank you again for the quick rseponse. Copying over the .yy file just swaps the entire room out, which of course restores the tiles but the problem is it overwrites all of the work I've done on the objects, sprites etc.

What I need to do, it seems, is ONLY copy/export the tile layers from the old version and import them into the new one. Is there a way to export a layer from a project to import it into another? Or copy and paste one layer from one room to another? I am googling around but to no avail so far.

I've not heard of "version control" before - again googling isn't making me any wiser. Is this a specific feature I should know about? Or do you simply mean constantly using "save as" to create a string of backups after each change?

Apologies for stupid noob questions.
 

Roldy

Member
Or do you simply mean constantly using "save as" to create a string of backups after each change?
That is essentially what version control does but in a way that is manageable and will let you see the changes between each version. With the ability to add or revert different changes between versions.

It is not a backup tool. It is a versioning tool.

Look into either Git or SVN as those are free and popular.

I am sure if you investigated the yy file you could find where the tiledata is stored and possible merge the two yy files you have. Again that is what versioning tools will help you with.

You might consider downloading something like Winmerge and see if it will help you out.
 
Thank you very much, that sounds like a rabbit hole I'm gonna have to go down! Hopefully can restore my work and avoid issues like this in the future.

I wish I knew how this happened. I definitely did not touch those variables myself, I simply loaded the project in the state I left it. Its very strange.
 
Top