Particle Effect - Depth Issue? [SOLVED]

brda666

Member
Hi all - firstly thank you for taking the time to read this!

The issue I'm having (I believe) relates to depth for sprites and the pre-made particle effects. I have attached an image which demonstrates my issue.

The image on the left is what I want - but the image on the right is what I'm currently getting.

The main difference between these two images is that the green area is a background image on the left, and a sprite on the right. Based on these results I assume that it's a depth issue (sprites versus effects)?

I'm using the default particle effect called 'smoke'. My problem is that I have played with the depth settings for the objects involved. Let's called them obj_Hill and obj_Splat. When my user left clicks I want to generate a red puff of smoke on top of obj_Hill but it is occurring underneath.

Additionally I have already selected for the smoke effect to appear 'above objects'. Neither this nor adjusting the 'depth' variable for any of the objects involved is yielding any success.

Doe anyone have any suggestions?
 

Attachments

Jaqueta

Member
You probably have your background checked as Foreground, from what I know, Foregrounds are draw on top of everything else in the game.

Your best shot is not use foregrounds. Instead, using alternative methods to draw this into your game, such as Tiles.
 

brda666

Member
You probably have your background checked as Foreground, from what I know, Foregrounds are draw on top of everything else in the game.

Your best shot is not use foregrounds. Instead, using alternative methods to draw this into your game, such as Tiles.
Thanks for the response. I don't actually want to use the backgrounds at all - I was just explaining how I was demonstrating the result.

What I need is for the red smoke effect to work on top / above the obj_Hill sprite. However no matter my efforts I cannot get it to work. I have tried adjusting 'depth' for all the objects related to the issue but to no avail....
 

brda666

Member
[Solved]

Changed the drag'n'drop variable for the particle to 'below objects' instead of 'above objects' - makes no sense for it to work but it does!
 
Y

Yokomokoloko

Guest
[Solved]

Changed the drag'n'drop variable for the particle to 'below objects' instead of 'above objects' - makes no sense for it to work but it does!
Hi,

Yesterday, I started up an old 'game' I had made months ago and have the same issue (but the other way around to yours). In my case, all built in particle effects are appearing in front of other objects now whereas they were originally appearing below. As you mentioned, brda666, changing the particle action from 'below objects' to 'above objects' draws the particle how I originally intended... to be drawn below other objects!..... looks like a bug in GM to me... haven't looked yet but there must be a place to submit bug reports for GM.... I'll try to submit a report if one hasn't been already.
 
Top