Android [partially solved?] "BUILD SUCCESFUL" but crashes on startup?

Discussion in 'Legacy GameMaker Community Tech Support' started by GreySilence, Feb 3, 2017.

  1. GreySilence

    GreySilence Guest

    GMS 1.4.1763
    Windows 10 x64
    Android Nexus 5 Phone

    Build Tools 23.0.1
    Support Lib 23.1.1
    Target SDK 23, Min SDK 9, Compile SDK 23

    The game seems to compile properly, as there are no errors that show up when hitting "Run the Game" on GMS. It even says BUILD SUCCESSFUL. On my device, it just says "Unfortunately, <gamename> (As YoYo Runner) has stopped." and behind it, shows a confirmation window saying "Allow <gamename> (As YoYo Run... to access photos, media and files on your device?" to that I hit allow.

    After hitting allow, it crashes and closes instantly. Every time after that I've tried to start it, it would crash instantly too. But if I delete the APK off my device and try to run it again, I get the first thing happening once again.

    The game runs on windows and windows YYC (It's not an issue with the game's programming, it's simply a one-room game with one object that draws text saying "Hello World!"). It also lets me create an executable file if I select "Single runtime executable (*.exe)" but gives me an error "Error with Installer!" if I try to create it using "Windows NSIS Installer (*.exe)".

    It seems to let me create a .APK, which I tried putting manually on my phone, but after installing it, gets the same instant crash. BTW the APK was created using both "Target: Android/Fire" and "Target: Android/Fire YYC" and they both have the same crash.

    I tried giving the APK to my friend, but it crashes on his phone as well. I suspect that the created APK is broken, as he can run the game fine normally on his phone/computer with the project files.

    Also, not sure if it has anything to do with the errors, but the splash screens on this window says "broken" http://i.imgur.com/gztygW7.jpg

    "Run the Game" using "Target: Android / Fire YYC":
    CMD Window: http://pastebin.com/3uGkFCv6
    Compile Window: http://pastebin.com/iXWdzfpn

    "Run the Game" using "Target: Android / Fire":
    CMD Window: http://pastebin.com/7us4Hqye
    Compile Window: http://pastebin.com/9tnCWHqe

    EDIT: Forgot to mention, Everything used to work fine for me a year ago, using the same phone on windows 7.
     
  2. GreySilence

    GreySilence Guest

    Ok, I found a solution on another post lol. Just use the 32 bit NDK even if you're on a 64 bit system.
    Pretty sure I'm using the 64 bit JDK, but if it's still not working for you, use the 32 bit JDK as well.

    EDIT: got a bit excited when it started running on my phone, but I still cannot create the APK or NSIS EXE
     
    Last edited by a moderator: Feb 5, 2017
  3. I have the same problem, What version of Windows do you have? I used to have windows 7 and it worked fine, But I recently Update my computer to Windows 10, Now Android export seems to not work. I mean, yes, there's no errors in game maker, but is something in the android export. I did the thing that you said, I changed the NDK and also the JDK... Didn't work. I'm going to install Windows 8! I'll tell you if it works in other operative system.
     
  4. Bingdom

    Bingdom Googledom

    Joined:
    Jul 1, 2016
    Posts:
    1,677
    What JDK version are you using? I think you should be using 8u102.
    64bit and 32bit shouldn't make a difference and NDK only affects the YYC.
     
  5. imineti

    imineti Member

    Joined:
    Nov 15, 2018
    Posts:
    21
    Did you ever solve the problem?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice