• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows Object doesn't show up when played (New to GameMaker)

ZackW

Member
I just got GameMaker Studio 2 very recently

I want to at least get familiar with the interface, but when I try to add an object in the room it doesn't show up when played. I tried using clean but it didn't do anything.
I didn't write any codes inside the object and I don't know what else to do

All of the objects are checked visibleGMCapture.PNG

(I reinstalled but still have the same problem)GMCapture2.png
 

simes007us

Member
If you open the object dialog is "visible" checked? Next, if you have a event called "Draw" even if it's empty it will override the check box in the interface. If that's not it are you using views and is the object in the view?
 

ZackW

Member
If you open the object dialog is "visible" checked? Next, if you have a event called "Draw" even if it's empty it will override the check box in the interface. If that's not it are you using views and is the object in the view?
GMCapture3.png

My sprite is said to be visible and I've added the Draw event but still it doesn't show up.
And I doubt I was using views because one time it worked on another test project but when I came back to the project it ended up not showing ingame.
 

simes007us

Member
View attachment 34018

My sprite is said to be visible and I've added the Draw event but still it doesn't show up.
And I doubt I was using views because one time it worked on another test project but when I came back to the project it ended up not showing ingame.
Please remove the draw event from the events section. Having that in there overrides game makers default. If you wish to control the draw yourself. Double click the draw event to open the editor and type "draw_self()" Those are curly brackets fyi

Capture.PNG
 
Last edited:

Chaser

Member
Another thing to check is your Sprites origin(x,y) sometimes I can accidentally click somewhere in the editor box when manouvering around the IDE and set it miles away without realising which could place it outside the game screen view. It’s possible you may of done the same.:)
 

ZackW

Member
Another thing to check is your Sprites origin(x,y) sometimes I can accidentally click somewhere in the editor box when manouvering around the IDE and set it miles away without realising which could place it outside the game screen view. It’s possible you may of done the same.:)
I've looked at my origin and it is completely in the middle center. Still I appreciate your advice, when I just started to explore functions of the system I tested my sprite with the background and it seems that it doesn't show up. I am guessing this is because this version is buggy due to the fact I cannot play one of the demo presets. Do you think the problems can occur depending on what version you are in?Capture4.PNGCapture5.PNG
 
Me and some other guys in the forum have the same problem. For me there is a problem with the new 2.3.0 version. In fact Ihave reinstalled the previous one and all work. I have reported this problem as a bug to YoYo but they gave me different confused answers like change the processor or stop the antivirus. I hope that this bug will be resolved soon.
 
Top