GMS 2 'Noob question' my variables are not tuning blue =(

2

2cute2die

Guest
Hi total noob so please be gentle.

I'm following a 'spelunky' style level gen tutorial and im currently making a script. my issue is when i try to set some variables in the IDE they do not turn blue, also some of the other parts of the code do not change to the colours of the tutorial.

so my question is, am i doing something wrong? can i set variables in scripts or do i need to set them elsewhere first?

the variables are 'xTiles' 'yTiles' 'inst'
also the 'levelData' isn't yellow =(

here is the tutorial im following, i have timestamped the part where you can compare ur code
 

Attachments

B

BGamers11

Guest
Did you try to wait a bit or like close and re-open the window, or click in the window? I also don't think that theres is a problem on variables not turning blue or levelData turning yellow... Pardon me if I'm being rude...
 
2

2cute2die

Guest
hi @BGamers11 , thanks for the response, no your not rude at all, yeh i waited and clicked out and even looked around as i thought maybe i had to set the variables elsewhere. buuuutttt i just closed the program and reopend when i saw your response and all the colours are correct. so i guess the classic turn it off and on again would of worked. i attached a pic but it hasnt shown as i have under 5 posts.
 
The person on your tutorial is probably using a different color-coding setting on the script editor. If you go to preferences, you can change the colors of the text in your code editor.

The color you choose to use don't mean anything. They are just for looks. But it's useful to have some sort of color scheme so you know that you are typing things correctly.

Long story short: It's nothing to worry about ;)
 
Top