Question - IDE Newly installed font doesn't show up in 'Fonts' dropdown menu

Discussion in 'GameMaker Studio 2 Community Tech Support' started by wee_ooh, Jan 6, 2019.

  1. wee_ooh

    wee_ooh Member

    Joined:
    Jul 31, 2018
    Posts:
    3
    Hi all,

    I'll describe the entire sequence of events that led to this bug, in case any of it is relevant. I was working on a project a few months ago in which I installed a font (Munro) on my machine, and then added the font to my project as usual with no issues. I took a break from the project during the college semester, during which time I reinstalled Windows 10 on my machine.

    Now I'm getting back to the project, and when I reinstalled GMS2 on my fresh Windows install, opened the project, and clicked on the Font Object, I got an error message saying that the font couldn't be found (expected, as I hadn't yet reinstalled the font).

    However, after reinstalling the font, the error message persisted. I deleted the Font Object and created a new one, but the newly installed font was not in the dropdown menu for font selection. I deleted the Font Object, reinstalled the font, restarted Windows, and started GMS2 up again, but the font was still not present. The font is correctly installed in the Windows/Fonts folder, and is usable in MS Word and other programs, but not in GMS2.

    I'm thinking maybe it's some kind of project-level data caching issue? Is there a way to clear caches in the GMS2 IDE? Is there something I'm overlooking, or should I submit a bug report for the issue?
     
  2. immortalx

    immortalx Member

    Joined:
    Sep 6, 2018
    Posts:
    224
    I don't know if it's related (probably not), but I had an issue with GMS2 recognizing a specific font for the code editor (not for a project). The dropdown on the code editor preferences, wouldn't list that specific font at all.
    Just like you, every other application would recognize and use that font perfectly. The workaround was to place it in the "C:\Program Files\GameMaker Studio 2\Fonts" directory.
    Give it a try.
     
  3. wee_ooh

    wee_ooh Member

    Joined:
    Jul 31, 2018
    Posts:
    3
    That did the trick! Thanks for the reply.

    Odd behavior, though. By all accounts, one should be able to access the font in the IDE simply by installing it. At least the workaround is simple enough.
     
    immortalx likes this.
  4. immortalx

    immortalx Member

    Joined:
    Sep 6, 2018
    Posts:
    224
    Yes, that seems odd. I didn't report a bug because my guess was that it had to do with the tons of fonts I have installed on my system. If a 3rd person can confirm the same behavior I think it would be safe to assume it's a bug
     
  5. immortalx

    immortalx Member

    Joined:
    Sep 6, 2018
    Posts:
    224
    If anyone wants to help decide if this is worthy of a bug report, please follow these steps:
    • Download and install this font. (You could try with other fonts too, but this particular one I tested in 2 different machines and it would refuse to show up first time.)
    • Fire up GMS2 and navigate to File->Preferences->Text Editors->Code Editor
    • Try to change the font in one of the fields. You probably won't be able to find this font.
    • Close GMS2 and copy the font to the C:\Program Files\GameMaker Studio 2\Fonts directory.
    • Relaunch GMS2 and try to change the font again. You should be able to find it.
     
  6. rmanthorp

    rmanthorp YoYo Games Staff Admin YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    222
    immortalx likes this.
  7. immortalx

    immortalx Member

    Joined:
    Sep 6, 2018
    Posts:
    224
  8. xcession

    xcession Member

    Joined:
    Aug 8, 2017
    Posts:
    1
    I have similar issue but on macOS. The font picker seem to only show "system fonts" and not include "user fonts".
    Because it different than Windows on macOS that have two separated font locations "/Library/Fonts" and "/Users/[USERNAME]/Library/Fonts".

    I have to install new fonts in "system" instead of my "user profile" in order to use it in GMS.
    Hope this fix in upcoming update too.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice