• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

New IDE and resource load failure(sprites mainly)?

So I got the new runtime/IDE installed and opened up a file- promptly experience massive resource load failures. Everything sprite got wiped. Did I do something wrong? I have backups, but I'm terrified to corrupt any more files with this new runtime/IDE...

What worries me is I can't seem to find anyone else talking about it. Is there something I did wrong?

Any insight is really appreciated!
 

TsukaYuriko

☄️
Forum Staff
Moderator
You have nothing to fear when operating on a copy of a project... :)

WIth that said, make one such copy and try again. Does the same thing happen again? If so, please file a ticket and attach the project.
 
You have nothing to fear when operating on a copy of a project... :)

WIth that said, make one such copy and try again. Does the same thing happen again? If so, please file a ticket and attach the project.
Thanks again!
One other thing I've noticed is that build time has shot up considerably (and I just deleted a LOT of sprites). It's at 30% longer than usual, and climbing. Is there something I did wrong?
 

TsukaYuriko

☄️
Forum Staff
Moderator
Is this about the first compile after updating or also any subsequent compile? Any kind of monumental modifications since the last compile will automatically skyrocket the compile time because more parts of the asset cache have to be rebuilt.
 
Is this about the first compile after updating or also any subsequent compile? Any kind of monumental modifications since the last compile will automatically skyrocket the compile time because more parts of the asset cache have to be rebuilt.
Oh yeah- the first compile (with the corrupted file I mentioned) was about 50% longer compiling. Subsequent new copies of the same file (edit: uncorrupted copies I mean!) are all taking around 20% longer as well. It's not an exact science, but they are definitely taking slightly longer and I'm not sure why. I am dealing with long build times due to the project size anyway, (like 10-14 min usually haha) so I'm trying to crack down on that and cleaning house.

Sorry to bother with something that may just be my own fault, but will definitely submit the project file and a bug if nothing seems to change/work :) thank you for your responses, in any event!

(Update: Deleted a number of large sprites and rooms, and that smaller/leaner file is still taking 25-100% longer to build with the new IDE/runtime... whatever it is, the new version is a longer compile, at least for my machine. I saw this mentioned back in march by a user "DT_" I think it was. Will keep digging for more info!)
 
Last edited:
For anyone else out there with a similar problem, It's confirmed, fresh newly created files take 100% longer to build with the new runtime. The first compile will ALWAYS take twice as long as it used to with the old one (from december I think)

Subsequent compiles of the game will be relatively short, and are about what they were before I updated. It's pretty vexing. Not sure if its the runtime, a problem with windows defender, or something deeper. Going to try to live with this, but it's a bad problem to have (and thankfully, it sounds like I'm in a very small minority here).
 
Top