• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

 My Room Manager is not working the way I want it to.

So when I run my game, the first room that loads up is not the the first room I want to load up. It shows a blank screen that shows no order of rooms. Whenever I try and drag rooms into the order manager, nothing happens; nothing pops up. Same thing with the asset browser itself. Whenever I try and manually change the order of the rooms in the asset browser by dragging the rooms to different positions, they never move.

The following video should explain it more:
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
Moderator
Looks like the room manager has become corrupted in some way. Try resetting the layout (from the Layouts menu at the top). If that doesn't work, export the project as a YYZ and then re-import it and save it under a new name... and if THAT doesn't work you're going to have to file a bug report with YYG and include the YYZ of the project so they can look into the issue.
 
I also tried to work around the problem by naming them differently so GMS can sort them out immediately, it seemed to work on the room inheritance on the Room Manager but when I tried to run the program, the program still loaded up Level2 and not Menu


I'm gonna send this problem to YYG Support.
 

Shut

Member
Exporting the project and importing it back might solve some of the issues with the room manager. I had an issue where the room manager order didn't work anymore and that helped.
 

rIKmAN

Member
I reopened the project and these symbols showed up.

View attachment 38306
I think they are the icons for the built in source control when the files have been changed since the last commit.

Is your project hosted on Google Drive whilst using source control?
I noticed the links you posted are Google Drive links so thought it was worth asking as working on projects from a cloud drive can cause weird issues as they lock/sync files which causes GMS2 to have problems.
 
SOLVED!

I just needed to update the software. I have GMS on my school computer and the teacher was not aware i needed to get rid of the admin download blocks school computers get, so I can update GMS.
 
Top