• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows my gamemaker studio 2 wont let me make an installer for my game.

I have a game I have been making on gamemaker studio 1.4.9999 then I upgraded it to gamemaker studio 2 and it will only let put it into a zip file with a stand-alone .exe inside how can I make it so it goes into an installer?

in image one that is the button,gamemaker1.PNGgamemaker2.PNG I hit circled in red in image 2 that is the only menu that comes up from hitting the button in image one.gamemaker1.PNGgamemaker2.PNG
 

rIKmAN

Member
If you go to File > Preferences > Platform Settings > Windows there is a dropdown for "Default packaging type".
Click this and you can choose between .zip, .nsis installer or have a dialogue shown to allow you to choose each time you build the project.

Remember to hit the "Apply" button after you have changed the setting to save the change.

I assume it is currently set to .zip so you aren't being given the option to choose when building.
 

Sybok

Member
I always go Build > Create Executable or Crtl F8, out of habit more than anything. If gives you the choice that way though.
 

rIKmAN

Member
I always go Build > Create Executable or Crtl F8, out of habit more than anything. If gives you the choice that way though.
Not if one or the other is set in preferences - it only gives you the option for that specific choice n the Save As dropdown.
 

Sybok

Member
Oh ok. Never played around in preferences for that particular setting. Probably always been set to the default for me.
 

rIKmAN

Member
Oh ok. Never played around in preferences for that particular setting. Probably always been set to the default for me.
Yeah I think the default is "Show Dialog" which gives the popup to choose, so if OP hasn't specifically changed that then I'm not sure why it would be set as .zip for the default in preferences.

I only know cos the popup annoyed me so I changed it to .zip ages so I don't have to keep seeing the choice window when building an exe.
 
If you go to File > Preferences > Platform Settings > Windows there is a dropdown for "Default packaging type".
Click this and you can choose between .zip, .nsis installer or have a dialogue shown to allow you to choose each time you build the project.

Remember to hit the "Apply" button after you have changed the setting to save the change.

I assume it is currently set to .zip so you aren't being given the option to choose when building.
didn't work it was set to show Dialog and I changed it to NSIS and it still came up with the zip thing.
 

Attachments

Last edited:
Top