Music files now make glitchy pop noises

Discussion in 'Legacy GameMaker Community Tech Support' started by TheBaconMan, Apr 28, 2019.

  1. TheBaconMan

    TheBaconMan Member

    Joined:
    Apr 3, 2019
    Posts:
    29
    This happens mostly on one file, game menu music that repeats. But I now hear it occasionally in the game music.

    I'm currently using WAVs for music - compressed, not streamed (not the uncompress method).

    I can't use streamed, because I need to keep the audio files hidden in the compile.

    And lastly, I have my music sound turned down to .5. No pitch change like the other guy with a problem.

    Gamemaker 1.4.
     
  2. Mick

    Mick Member

    Joined:
    Jun 30, 2016
    Posts:
    725
    You are probably using a version newer than 1.4.1772? The audio engine was replaced and was never fully fixed it seems.
     
  3. TheBaconMan

    TheBaconMan Member

    Joined:
    Apr 3, 2019
    Posts:
    29
    1.4.999999. So you're saying it might have been left with issues when they moved to 2?
     
  4. Mick

    Mick Member

    Joined:
    Jun 30, 2016
    Posts:
    725
    I'm not sure, but I have seen several people talking about stuttering etc. on versions beyond 1.4.1772.
     
  5. TheBaconMan

    TheBaconMan Member

    Joined:
    Apr 3, 2019
    Posts:
    29
    Good to know. I'll just make the worst offender uncompressed and live with the rest. Thanks!
     
  6. TheBaconMan

    TheBaconMan Member

    Joined:
    Apr 3, 2019
    Posts:
    29
    It seems like using WAVs with the "uncompress on load" method does not cause any pops. Good deal.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice