• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Android MOGA change in latest build

Jeff Mundee

Member
I am getting a failed compile now with our game's Gamepad support after updating to the latest build 2.2.1.375

Under the release notes I see:
  • Game Options: Removed the checkbox for MOGA Gamepads from Android, as this is no longer relevant in 2.2.1+ runtimes, as we have changed the gamepad integration
We had this unchecked.

What can I do?

symbol: method addMogaDevice(<null>)
location: class Gamepad
W:\game\MogaExtensionAndroid.java:84: error: cannot find symbol
if (Gamepad.msMogaDevice != null) {
^
symbol: variable msMogaDevice
location: class Gamepad

I get several of these in the output of the compile for android.
Compiled fine yesterday before update.

Thanks,
Jeff
 

rIKmAN

Member
Make sure Android is selected as the target in the IDE and your device is plugged in, then clean the project with the broom icon at the top of the IDE.

Now try recompiling and see what it says.
 

Jeff Mundee

Member
Thanks rIKmAN,
I tried that and beyond. Thanks for the compile suggestions.
I also turned it off, and then turned it back on again, like a true IT Troubleshooting Master.
I rolled back the master runtime and pushed out an APK on 2.2.0.258 without issue.
But that is not my point.

If the MOGA checkbox is no longer needed as they suggest, why is the new version breaking on my gamepad code? - this needs a look by YoYo Devs.
New version of GMS2 2.2.1.375 needs a QA pass on the MOGA and Gamepad changes.

Yoyos, are you still there?
There will be cake. Promise.

Jeff
 

clee2005

Member
I just got this and tried to clear the cache but was unable due to a locked file. I manually went and deleted the cached folders and was able to build successfully after that.
 
Top