• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Question - Code Missing Pixels (not scaling/interpolation issue)

Status
Not open for further replies.
Hi all,

This is my first post. I am new to GameMaker but have done about 3 different tutorials (asteroids, farming RPG, blaster faster) and have started to make my own game, and I have come up against my first issue which I can't find help for.

I made my title screen on GIMP at 1280x720 pixels. I then exported it to PNG and made it into a sprite and put it as the background of my first room. It all looks fine in the room editor, but when I run the game, pixels go missing, and shapes go wonky. Just in case it's relevant, I'm using a MacBook.

The room size is also 1280x720, so scaling shouldn't be the issue, and 'interpolation' shouldn't be the issue either (i have it unticked in any case). I created a camera/viewport at 1280x720 to try and fix, but the same issue occurs. If I make a camera at 640x360 and run the game, though, there aren't missing pixels or shape problems, which is leading me to believe that maybe game maker can't handle all individual pixels at that resolution? Or maybe it is because some pixels' alpha value is too low at that distance and so game maker cuts them out? I have attached two screen shots of just the title text and moon of the title screen to show how it looks in the room editor and how it looks when I click run game. You can't see the whole title screen, but it's reallllllly cool (I think!) and I would be devastated if I had to remake it at a different resolution because I spent so long on it! :(

I would be so grateful for a solution :)
 

Attachments

rodrigo1434

Member
Make sure that both view width and view port width are the same in this case, otherwise the view you get will be with some distortion.
1588477284370.png
 
Hi Rodrigo - your screen looks different from mine so I assume you are using GameMaker 1, but I had already made it so the room size, camera view (I think this is 'view in room' in your picture) and viewport properties are all the same size.

I spent all yesterday trying various different things, but still can't see why it happens. Funnily enough, if I make the text of the title screen into an object, and then make the text object move, the text does not show missing pixels as it is moving and only misses pixels when it comes to a stop (and it misses different pixels depending on where in the image it stops)
 
Status
Not open for further replies.
Top