• Hey! Guest! The 37th GMC Jam will take place between May 28th, 12:00 UTC and June 1st, 12:00 UTC. Why not join in! Click here to find out more!
  • Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Mac OSX MacOS export won't start with Steam enabled [Solved]

thom

Member
I have GMS 2 running on MacOS, when I try to export as YYC and without Steam enabled the project works. However, when I check "enable steam" in the MacOS Options menu and fill in the right Steam ID at Main Options - General it won't run the compiled executable (YYC or VM, but Run in GMS 2 does work). When I run the game in Xcode after exporting it as YYC the game opens and closes immediately after the splash screen and an Xcode message is shown:
Ultimate Racing 2D is attempting to launch with the optional parameters shown below. " '-NSDocumentRevisionsDebugMode' 'YES' " if you did not request this launch or do not understand these options, select Cancel.
I have already released my game Ultimate Racing 2D on Steam for Windows and have everything set up for the MacOS platform at Steamworks Partner and I have downloaded Steamworks SDK.
I'm using the GMS 2 Mac IDE because compiling from my windows laptop didn't work even though it works for iOS.

Is this a known bug, because it happens even when creating a new empty test project.

Edit:

Ok, I've just figured out that I somehow made a mistake at partner.steamworks.com when setting up for Mac. After recreating everything there for Mac it works again.
 
Last edited:
Top