• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Mac OSX macOS always compiles to VM

This is a very strange issue I've started having - every time I try to build for macOS and YYC, it seems to work - but when I launch the finished app, it's the Runner version. I suspected when I saw the default splash screen, then verified this by executing via terminal - the output starts with:

***************************************
* YoYo Games Mac Runner V0.1 *
***************************************

This happens whether I compile directly on my mac or on my windows machine connecting to my mac.

Things I've already tried:
  • Wiping all cache folders
  • Wiping the xcode project folder
  • Doing "Clean project", both locally and remotely via windows
  • Restarting GM and the mac
  • Triple-checking that YYC is the selected target
I'm on GMS 2.3.1.542 and using runtime 2.3.1.409. However, the problem didn't start immediately after updating - I've been working through some code signing issues and doing lots of builds, and up until recently they seemed to work correctly (in that "YoYo Games Mac Runner V0.1" was not present in the terminal output unless I selected VM as the target).

The most recent change I'm aware of before this started happening was a code signing one - I changed my Signing Identifier in the macOS Game Options from "Developer ID Application: <My Name>" to "Developer ID Application: <My Team Name> (<My Team ID>)". After making this change, my next build threw an error: "security: SecKeychainUnlock <NULL>: Unable to obtain authorization for this operation. -reset" when trying to execute: "security unlock-keychain -u && security find-certificate -c 'Developer ID Application: <My Team Name> (<My Team ID>)'". As part of my debugging, I ran that same command from the terminal - but it worked. I immediately built again, and the problem seemed resolved - but that's the first time it built the VM version instead of YYC. Since then it only builds VM no matter what I do.

I have no idea if any of the code signing stuff is relevant or just a cosmic coincidence, but figured I'd include it just in case.

Is there any other type of cache I can clear? Anything else I can check for? I can provide the full build log if necessary, but it contains sensitive information that I haven't sanitized yet.

Any ideas much appreciated!

I'm on macOS Catalina 10.15.6 and Xcode 12.3.
 
Well, I've since verified that it's happening on other macs (so apparently not an environment issue) and on a new, empty project (so apparently not a project issue). I'm going to report it as a bug to YoYo at this point.
 
Top