1. Hey! Guest! The 35th GMC Jam will take place between November 28th, 12:00 UTC - December 2nd, 12:00 UTC. Why not join in! Click here to find out more!
    Dismiss Notice
  2. Hello Guest! It's with a heavy heart that we must announce the removal of the Legacy GMC Archive. If you wish to save anything from it, now's the time! Please see this topic for more information.
    Dismiss Notice

Windows Layers don't work properly in the sprite editor?

Discussion in 'GameMaker Studio 2 Community Tech Support' started by Chris Wilfong, Jan 31, 2017.

  1. Chris Wilfong

    Chris Wilfong Member

    Joined:
    Jan 31, 2017
    Posts:
    9
    I wanted to create a character animation using separate layers for front arm, front leg, back arm, back leg, etc. However, when I create a new frame the images start switching themselves to other layers and it gets extremely glitchy. Has anyone else had this problems/found a way to get around it?
     
  2. gn.fur

    gn.fur Member

    Joined:
    Jul 20, 2016
    Posts:
    99
    Just use Spine or any normal image editor. Photoshop, Paintdotnet, anything.
    And submit bug to buglist. They'll fix it. In 4 to 6 months. : - )
     
  3. Chris Wilfong

    Chris Wilfong Member

    Joined:
    Jan 31, 2017
    Posts:
    9
    Lame haha
     
  4. gn.fur

    gn.fur Member

    Joined:
    Jul 20, 2016
    Posts:
    99
    It's just built-in editor, why do you even use it for anything other than minor sprite modifications? Yes, it got better in GMS2, but it's better to use dedicated software for main work. (and do this kind of animation with skeletons.)
     
  5. Candied Hat

    Candied Hat Guest

    It would be nice to ensure able to use Game maker by itself to do image creation and editing. It's a great editor, it just has a few bugs.
     
  6. Mike

    Mike nobody important GMC Elder

    Joined:
    Apr 12, 2016
    Posts:
    2,396
    Now now.... We've been pretty good at fixing issues in GMS2, especially stability or project related things.

    Can you get a repo case of this? a GIF/Video of it happening?
     
    modalmodule likes this.
  7. modalmodule

    modalmodule Guest

    I'm having the same issue, and now every time I copy paste a frame, then hide then show or edit a layer, it happens: literally the images held in the layers randomly shuffle, like a really annoying Chinese fire drill! Meanwhile the previous frame has the images of the layers in proper order...
     
  8. Mike

    Mike nobody important GMC Elder

    Joined:
    Apr 12, 2016
    Posts:
    2,396
    I've reproduced this and filed a bug. Thanks for the repo cases - these are MASSIVELY helpful. :)
     
    modalmodule likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice