• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows Laging but not actual FPS drop with new version 2.3.2.420

makas

Member
Hello I came back to keep working on my game that I stopped working on like for 6 months, of course there was a new version of gms, I updated and run the game and everything seems to be alright with the project, the only issue that is very annoying is that the game it seems to be laging (the last time I worked on this game wasnt lagging at all and I am using the same PC, the same windows installation etc) so I checked my debug to see how much the FPS were droping and for my surprise the FPS are not droping at all I have between 1100 and 1360 FPS all the time, but the game is still visually laging... anybody else having a similar issue? anyone can help me to track down what is the issue?

I though it could be a memory leak, a loading of a texture or something like that, but I am been trying to get my texture groups in check and load them at the start of the game so this slow downs dont happen I been checking the task manager and I am cosuming only 137 MB of ram, using only 15% of the cpu and 20% of the GPU, and also they dont happen in the same part of the game the slow downs are just at random places so I dont know what is really causing the issue any help would be really appreciate it.

edit: further investigation on my issue added some details... it seem when I am using in my debug the function FPS instead of FPS_REAL it does change the frame rate a bit, when I notice the lag the number change from stable 60 to 58-61 FPS but is way more noticiable than 1-2 frame drop, also why in the hell it would go above the 60 fps limit of my screen?

edit2: more details it seems to only happen when I am on full scree mode, and only on one of my screens I have a screen connected with hdmi with 1920x1080 resolution and I have another screen that is display port with 2560x1440 resolution... this issue only happens on my bigger screen and in full screen mode, doesnt happen at all in windowed mode
 
Last edited:

Nocturne

Friendly Tyrant
Forum Staff
Admin
Moderator
What is the monitor refresh rate? I'm asking because reading this reminded me of this thread:

Have a read through that and see if anything seems applicable to your situation. :)
 

makas

Member
What is the monitor refresh rate? I'm asking because reading this reminded me of this thread:

Have a read through that and see if anything seems applicable to your situation. :)
sorry was busy working all week and thank you very much for your response, and all my monitors are 60 hz so I think is not related also is no the same issue because it seems like in that post all the game is slowdown to 75%, in my case I have lag spikes 80% is running well
 
Top