• Hey! Guest! The 39th GMC Jam will take place between November 26th, 12:00 UTC and November 30th, 12:00 UTC. Why not join in! Click here to find out more!
  • Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

iOS Issues with iOS build with Google Play Services Extensions

Tony M

Member
Hi, I have come across an issue with trying to build to iOS. When I try to build with GooglePlayServicesExtension added, I get the following error when trying to build on XCode:

Undefined Symbol: _OBJC_CLASS_$_PACConsentForm
Undefined Symbol: _OBJC_CLASS_$_PACConsentInformation

Screen Shot 2019-07-09 at 8.04.55 am.png

If I remove the extension and try to compile, the error goes away (no other changes to the code) and I can run it on my iPad no problems.

This means I cant get Ads and IAPs working on my iOS build of the game. I have been able to get Ads (with EU user consent) and IAPs working on my Android build but this error is stopping me from release on iOS.

I just upgraded to the latest version of GMS2 (v2.2.3.433), removed and re-added GooglePlayServicesExtension (3.1.2), and run Clean before compliling. The version of XCode I am running is also the latest version (10.2.1). I have also tried changing the target within XCode from 8.0 and 9.1 and rerunning but still get the error.

Hoping someone is able to assist.
 

Dan

YoYo Games Staff
YYG Staff
Version 3.1.2 of that extension has an issue with some missing iOS libraries. This has now been fixed and a 3.1.3 will be released shortly. Once that's available, ensure you clean your cache and your builds should then work.
 

Tony M

Member
Thank you Dan, I wasn't aware it was a bug. Was worried I was doing something wrong.

I've noticed a couple of other things like set test device not working for Test Ads (GoogleMobileAds_UseTestAds) or EEA Consent (GoogleMobileAds_ConsentDebugAddDevice). This works for me in Android export but not iOS. Hoping the new version will also resolve these? (tried to search in the bug database but couldn't find anything)
 
Hello.

With the version 3.1.7 I got this error:

[1078:300789] Reward based video ad failed to load.
[1078:300789] Error Code: undefined
[1078:300833] <Google:HTML> You are currently using version 7.27.0 of the SDK. Please consider updating your SDK to the most recent SDK version to get the latest features and bug fixes. The latest SDK can be downloaded from https://goo.gl/UoiJ8F. A full list of release notes is available at https://developers.google.com/admob/ios/rel-notes.

I need help with that, please.

Regards.
 
Top