Question - Uploading internal server error (500)

GMWolf

aka fel666
I have been trying to upload an asset for a while now but i keep getting an server internal error report (500).
I have been trying every few days but it doesnt seem to work. THe packages do show up on the marketplace website but are stuck on porcessing.
Please, please fix this. I just want to update my package and not worry anymore.
(kids, don't sell code if its not your job, then you need to maintain it, especially if Yoyo are part of the pipeline, im starting to find them very unreliable.)
 

Appsurd

Member
I have send a message to the helpdesk weeks ago about this issue. Their reply:

- Try reuploading your asset at different times of the day and using different Wifi connections, which might help (didn't work for me)
- We are working on it but have no clue when it will be fixed
 

Chaser

Member
There’s a few of us that are having the same problem, help desk says(to me), they are working around the GM2 update, just to keep trying and hope it works.
 

Leoah

Member
I have send a message to the helpdesk weeks ago about this issue. Their reply:

- Try reuploading your asset at different times of the day and using different Wifi connections, which might help (didn't work for me)
- We are working on it but have no clue when it will be fixed
Yes, me too! don't know when they will complete fix it, hope they can do it as soon.
 

Samuel Venable

Time Killer
I've had this same problem and already created a topic about it long before this one existed and got the same exact response from the helpdesk.
 

FrostyCat

Member
It's still happening, and I've also filed a ticket. Someone seems to have screwed with the logic for accepting package uploads, and now the format it accepts without going 500 is no longer compatible with any current version of GMS 2. Surely a 30% cut should have bought better support than this?
 

YellowAfterlife

ᴏɴʟɪɴᴇ ᴍᴜʟᴛɪᴘʟᴀʏᴇʀ
Forum Staff
Moderator
HTTP 500 did happen in past and is non-indicative - your package still uploads to marketplace. What did change, however, is that assets now get stuck in verification phase - even when uploading them manually.
 

FrostyCat

Member
I've just had success pushing an update to my JSON Toolkit library (see the timestamp on its Marketplace listing). Apparently the integration from the IDE side is broken, but the upload form on the website still works some of the time.

This is how I did it:
  1. Export a local package containing the exact same details and contents as your original Marketplace product (make sure to sign it)
  2. Visit your publisher console in your browser, which should take you to your Assets page
  3. Select your asset to update from the list, which should take you to a form saying "Asset Listing"
  4. Click Versions
  5. Click Upload Version
  6. Upload your package, and specify the version and changes, then select Save.
  7. Wait for it to finish publishing.
  8. If it stays stuck on processing for more than an hour, go back to Step 4 and use the download button for the version you uploaded. Then go to Step 6 and upload the downloaded .yymp instead.
I got it on my fourth try this morning. All the previous attempts from last night and Monday were stuck on processing, even after receiving the "ready to be published" email.
 

Bart

WiseBart
I wanted to make another thread for this but it seems I'm not the only one experiencing this issue.

I tried a couple of things myself:
  • Initial upload through IDE: throws an HTTP 500 internal server error
  • Add a new version through the New Version page using a local .yymp, increment the version number just to be sure, but no success
All versions appear in the list but stay in 'Processing' state.
I did not sign the package, which I have done for assets in the past. Not sure if this could make any difference.

I'm not too sure if, for the time being, a workaround can be found for this that works 100% of the time.
Since it doesn't seem clear when exactly this issue is going to get resolved.
 

kburkhart84

Firehammer Games
Add another name to the list. When I was updating Firehammer Input yesterday the IDE gave me the same errors, and did the same thing, saying the update was in progress somehow. I did however upload the package directly to the website and it went through and seems to have completed just fine. I had already seen this post and that others had already reported it to the helpdesk so I wasn't worried about it. I also started selling on itch so considering the current situation of the marketplace I'm guessing I will likely get more customers over there than over here in all honesty.
 

Appsurd

Member
Yes I'm feeling I should start selling on itch as well. Not necessary because I don't like YoYo grabbing 30% or that I'm afraid people can't download or buy my assets (because that works nearly 100% of the time) but I would at least want a working upload system :(
 
Hi Everyone!

I get this error message after 2 weeks of the last message here...

Any Idea? Can anyone tell me a good solution or just a direction to go?
Asset uploading is the only reason why I purchased GMS2, and doesn't work :(
What can I do now?

Thank you for any answer / reply.

errorMess.jpg
 

FrostyCat

Member
I've already covered what to do. The solution is to upload manually through the browser.
  1. Sign into your account, then click Publisher, then click your publisher name.
  2. On the Assets page, click Add new asset and fill in the details.
  3. Fill in your Asset Listing form and save.
  4. Click Versions.
  5. Click Upload Version.
  6. Upload your package (must be signed), and specify the version and changes, then select Save.
  7. Wait for it to finish publishing.
  8. If it stays stuck on processing for more than an hour, go back to Step 4 and try uploading again.
I just published a new asset using this process, and it worked on my second try. Sure, YoYo's web dev team still has work to do fixing the IDE-side integration, but at least the browser-side form can suffice for now.
 
Last edited:
I've already covered what to do. The solution is to upload manually through the browser.
  1. Sign into your account, then click Publisher, then click your publisher name.
  2. On the Assets page, click Add new asset and fill in the details.
  3. Fill in your Asset Listing form and save.
  4. Click Versions.
  5. Click Upload Version.
  6. Upload your package (must be signed), and specify the version and changes, then select Save.
  7. Wait for it to finish publishing.
  8. If it stays stuck on processing for more than an hour, go back to Step 4 and try uploading again.
I just published a new asset using this process, and it worked on my second try. Sure, YoYo's web dev team still has work to do fixing the IDE-side integration, but at least the browser-side form can suffice for now.
Thanks Sir! :cool:

I really appreciate your quick answer! I just see it.
I'm going to check your solution and write my experience asap.

Have a great day!

Edit: I saw & read your solution earlier, I thought that is only an update method and not a brand new upload description. That's why I skipped that, sorry.
 
I've already covered what to do. The solution is to upload manually through the browser.
  1. Sign into your account, then click Publisher, then click your publisher name.
  2. On the Assets page, click Add new asset and fill in the details.
  3. Fill in your Asset Listing form and save.
  4. Click Versions.
  5. Click Upload Version.
  6. Upload your package (must be signed), and specify the version and changes, then select Save.
  7. Wait for it to finish publishing.
  8. If it stays stuck on processing for more than an hour, go back to Step 4 and try uploading again.
I just published a new asset using this process, and it worked on my second try. Sure, YoYo's web dev team still has work to do fixing the IDE-side integration, but at least the browser-side form can suffice for now.
Hey There!

I tried your solution a couple times and still doesn't work. Everything is fine except the processing. That doesn't want to disappear after my 4th and 5th try to upload. There are no way to download the original file because the link points me to this link: " https://marketplace.yoyogames.com/publishers/tools/assets/9113/versions " and not a valid download. So I'm totally clueless what to do now. IDE side is broken as you also mentioned, the web version has glitches, and useless too. And no any solution from YoYo, I tried to upload from IDE yesterday, still doesn't work. Dunno what to do...
 

FrostyCat

Member
Hey There!

I tried your solution a couple times and still doesn't work. Everything is fine except the processing. That doesn't want to disappear after my 4th and 5th try to upload. There are no way to download the original file because the link points me to this link: " https://marketplace.yoyogames.com/publishers/tools/assets/9113/versions " and not a valid download. So I'm totally clueless what to do now. IDE side is broken as you also mentioned, the web version has glitches, and useless too. And no any solution from YoYo, I tried to upload from IDE yesterday, still doesn't work. Dunno what to do...
You have to sign the package before uploading it. Someone tried my solution just a few minutes ago and it worked for him almost right away.
 

FrostyCat

Member
Try changing your package's display name to match your listing. Also, make sure that both the certificate in File > Preferences > Marketplace and the one registered with your Marketplace account are the same. Other than that, give around 10-20 minutes for the file to process, don't retry right away.
 
Try changing your package's display name to match your listing. Also, make sure that both the certificate in File > Preferences > Marketplace and the one registered with your Marketplace account are the same. Other than that, give around 10-20 minutes for the file to process, don't retry right away.
Yeah I have the same problems...
Plus I followed every single one of these tips, all the way through this thread,
point per point,
exactly as described,
and nothing works.
It remains stuck at processing.

At this point, I am amazed at the amount of incompetence of the uhum.... "work".... they did in making the marketplace a meaningful environment for developers.
I'm done with this, I'm going to Itch.

And may I add: anyone reading this: It is not worth your time and effort right now,
until they fix it that is,
to upload to the GM marketplace.
Find other marketplaces online and upload and sell there,
or otherwise you are just wasting a lot of time creating assets, and you will not see a return.

GMS marketplace is THAT broken.
 
Top