• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

SOLVED IDE Will Not Launch (Windows 10)

When I try to launch GameMaker Studio 2, nothing happens. Everything was working months ago, but I tried booting it up again today to help a friend with his game, and now it is now longer launching. This isn't an issue with just this latest release since I first tried using the previous version that I already had installed, and that had the same issue. I was hoping a clean install of the newest version, including deleting the folders from within %appdata% and %programdata%, would fix it but it did not. I also tried the Steam version with the same result. Running it as Admin did nothing. Windows is up-to-date as are my drivers.

Unfortunately, no GMS log files are generated from this, and when I try running it through command prompt, I just get a new prompt without any messages. Trying to launch it through git-bash, however, prints the following despite NativeBase.dll being present in the GMS folder:
Code:
Starting......

Unhandled Exception: System.DllNotFoundException: Unable to load DLL 'NativeBase.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)
   at YoYoStudio.Program.TestInstall.SetExceptionHandler(String _pProgramPathDir, String _programDir, String _ideVersion, Int32 _minidumpType)
   at YoYoStudio.Program.TestInstall.CheckDLLs()
   at YoYoStudio.Program.Main(String[] _main_args)
System Info:
Processor: AMD Ryzen 7 4700U with Radeon Graphics 2.00 GHz
Installed RAM: 16.0 GB (15.4 GB usable)
System type: 64-bit operating system, x64-based processor
Edition: Windows 10 Home
Version: 20H2
OS build: 19042.867
BitLocker is enabled


Any and all help would be appreciated!
 
Drivers were not actually up-to-date. Installed them directly from AMD rather than from my laptop manufacturer and now it works again.
 
Top