• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

 IDE missing mouse input messages?

H

Hieran_Del8

Guest
I've been using GMS2 for a while, and one problem that's been bothering is the mouse input becomes less responsive the longer the program is open.

I leave the program running for hours, over multiple sleep sessions (days if I could. I use Microchip MPLAB X and Microsoft Visual Studio as well, don't find it a problem using them for weeks without restarting.)

It seems both double-clicks and mouse wheel messages are not always being processed by the IDE. I've worked around this by every so often restarting, adjusting the double-click speed up to 450ms, and the scroll speed up to 2, but this is just masking an underlying issue.

My workstation:
Intel core i5-6402P @ 2.8GHz (quad core)
24GB ram
Windows 10 Home, x64
manufactured by CyberPowerPC
3x1 monitors, 1920x1080 each
AMD RX 480
 

Jobo

Member
GMC Elder
Please submit a bug report and attach the %programdata%\GameMakerStudio2\ui.log file(s) along with additional information like average framerate, etc.
 

gnysek

Member
help.yoyogames.com > submit request (remember to login first with YYG account, this would save filling some fields).
 

Dan

YoYo Games Staff
YYG Staff
Well, I would if that option were available on the bug report page: https://account.yoyogames.com/report-bug

It seems the option "GameMaker Studio 2.x IDE" does not have the form available for submitting a bug.
For users with a paid license, we're opening up a support forum for you to raise issues. That's why you have a button to go to the support forum rather than the bug-reporting form. However, this clearly didn't get communicated correctly in the midst of the launch last week, so apologies for that.

We're looking at re-jigging that page to probably add the form back in for everyone and have the support forum button as an optional extra, but rest assured you CAN still submit GMS2 IDE bugs and we ARE looking for reports to be sent to us.
 
H

Hieran_Del8

Guest
For users with a paid license, we're opening up a support forum for you to raise issues. That's why you have a button to go to the support forum rather than the bug-reporting form. However, this clearly didn't get communicated correctly in the midst of the launch last week, so apologies for that.

We're looking at re-jigging that page to probably add the form back in for everyone and have the support forum button as an optional extra, but rest assured you CAN still submit GMS2 IDE bugs and we ARE looking for reports to be sent to us.
Ah, got it. Thanks for the clarification!
 
H

Hieran_Del8

Guest
So the support forum helped me figure out it was the help browser causing everything to become less responsive. On closing that tab, responsiveness returned.
 
Top