• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

SOLVED I need some help: game source files not reading properly. (.yyp file possibly corrupt) - Trying to not lose several months of development.


So, I was working on a game I've been developing since late January of 2020, and GMS2 ended up crashing. This is no big deal, it happens from time to time. After I re-launched GMS2, I opened up the project again and while it was opening (loading all of the assets and whatnot), I closed all of the rooms that were open in the project (This is what I believe caused the problem to happen, as I have no idea what else could have). After the project finished loading, the Asset browser disappeared, and won't open again. The game can't build an executable anymore, and it can't run either.

(Windows->Asset Browser doesn't work) footage of issue

I tried restarting GMS2, I shut down and restarted my computer, and I even went as far as uninstalling and reinstalling GMS2. And, finally, after moving the files to a different pc and trying them, I discovered that the same issues persisted there as well. Also, other projects load up with no issue.

So, the problem wasn't on GMS2's side, this meant that something happened that somehow corrupted the .yyp file itself, making it essentially useless. Now, I've been working on this game for around 1 year and 8 months. The last backup I have is a good couple months old (I know, I've been kicking myself all night about that). I need to know if there's any way I can either restore the .yyp file to a working state (I had no luck with "restore previous version" in the properties tab), de-compile the last build I made into a workable version, or how I could move all of my game assets and information into a new project. All of the other files seem to be perfectly fine, but I can't seem to find a way to import them into a new project (Tools -> Create Local Package doesn't work either.)

I've been pushing to launch the full game on Nov. 1st this year (in a month and a half, as of posting), and this has seriously got me panicking.

Thank you for taking the time to read this. Any help is greatly appreciated!

yyp file screenshot.PNG